Results 1 to 5 of 5

Thread: VOD on Android

  1. #1

    Default VOD on Android

    can anyone tell me why on android our player is not working seamlessly? e.g. the video sort of works after a cumbersome series of clicks that launches a video player.
    experience is choky and unprofessional.
    it works well on all other platforms - we have jw player using flash and fallback for iOS - we are using WowzaMediaServer-3.5.0
    Last edited by bobmane; 09-09-2014 at 10:29 AM.

  2. #2

    Default

    Hi there.

    This would appear to be an Android issue as you are reporting that the stream works with other protocols. In the past Android has proven to be a little unstable. What version of Android are you testing on?

    Please take a look at this troubleshooting guide:
    How to troubleshoot RTSP/RTP playback

    You can also test your set up with this RTSP/RTP test stream to see if it works.

    Thank you.

    Salvadore

  3. #3

    Default

    Quote Originally Posted by salvadore View Post
    Hi there.

    This would appear to be an Android issue as you are reporting that the stream works with other protocols. In the past Android has proven to be a little unstable. What version of Android are you testing on?

    Please take a look at this troubleshooting guide:
    How to troubleshoot RTSP/RTP playback

    You can also test your set up with this RTSP/RTP test stream to see if it works.

    Thank you.

    Salvadore
    this is on latest android testing on in store devices at the mall

    why did you put rtsp? this is on demand "vod"

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    RTSP can be used for vod or live, it shouldn't matter.
    I tend to refer folks to the Android core media formats section of the Android developer guide here.
    where there are recommendations to use H.264 Baseline Profile codec. Which is basically keeping it simple to ensure playback across more devices.

    Salvadore's rtsp link above is to a test vod video with very simple encoding, should work on most devices.

    Daren

  5. #5

    Default

    we are using H.264 Baseline via handbrake and RTMP.

    support said:
    ------------------------------------------------
    For some Android devices you may need to add the following Property

    <Property>
    <Name>cupertinoOnChunkStartResetCounter</Name>
    <Value>false</Value>
    <Name>Boolean</Name>
    </Property>

    Into both

    LiveStreamPacketizer / Properties

    and

    HTTPStreamers/Properties

    Restart Wowza and this may resolve the issue you are seeing.
    -----------------------------
    which sounds like a maybe

Similar Threads

  1. Android VOD problem
    By sam.shm in forum Video On Demand Streaming Discussion
    Replies: 5
    Last Post: 06-30-2013, 06:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •