I have been stuck on this for a few days. I have been trying to stream an rtsp ip camera using aws and cloud formation but I cannot get wowza to accept the stream.

I originally started by following Live HTTP streaming with wowza on amazon just to stream my webcam and that worked fine.

I then had ec2 and wowza streaming engine setup and able to convert a rtmp stream and publish it using cloud front.
Then I followed How to re-stream video from an IP camera (RTSP/RTP re-streaming) on wowsa and using the same cloudformation that I had from the previous guide I added my ip camera to the stream files and connected it but when I look at incoming streams it always says that my status is waiting for stream.

I have tried this different ways. the first time I created the instance was by following the first amazon guide, and another time I created the instance myself following the wowsa streaming engine guide for amazon and choosing the ami myself

I am using a Vivotek network camera Model IP8372
I have the camera ports forwarded on a static ip and can access the stream using vlc from other networks

Any help on this would be greatly appreciated, Thanks