Results 1 to 4 of 4

Thread: New tricaster only publishes as flv files

  1. #1

    Default New tricaster only publishes as flv files

    We have a separate flash media encoder that we used with an older tricaster we purchased and every thing works. We recently purchased a TCXD40 and now I would like to stream to our wowza server as an mp4 just like we do with the FME. I cant find where you change this in the software. so when we stream now it is a flv file and will not play on IOS devices. When we stream live we can watch on all devices but after the stream is done the saved flv will not play on IOS devices.

  2. #2

    Default

    Hello there.

    What version of Wowza are you running? Previous versions would save to .flv by default, but as of Wowza 4 the new default recordings are saved as .mp4
    You can change what the default recordings are saved as by editing [install-dir]/conf/Server.xml:
    <Streams>
    	<DefaultStreamPrefix>flv</DefaultStreamPrefix>
    </Streams>
    Change to:
    <Streams>
    	<DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    Then restart the server to make the change take.

    And for the recordings already saved as .flv, you can use ffmpeg. Here are some example:
    How to encode video on demand content

    Thank you, and I hope this helps.

    Salvadore

  3. #3

    Default

    Quote Originally Posted by salvadore View Post
    Hello there.

    What version of Wowza are you running? Previous versions would save to .flv by default, but as of Wowza 4 the new default recordings are saved as .mp4
    You can change what the default recordings are saved as by editing [install-dir]/conf/Server.xml:
    <Streams>
    	<DefaultStreamPrefix>flv</DefaultStreamPrefix>
    </Streams>
    Change to:
    <Streams>
    	<DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    Then restart the server to make the change take.

    And for the recordings already saved as .flv, you can use ffmpeg. Here are some example:
    How to encode video on demand content

    Thank you, and I hope this helps.

    Salvadore
    Ok I am running version 3.12. I looked at the file and I do not see this any were in server.xml. Can I just add the code to the file?

  4. #4

    Default

    Hi there, I am sorry about the miss information. I found out today that Wowza added the ability to change the default prefix in Wowza 4.x, So you would not have been able to find this option in previous versions.

    Another option would be to prefix the stream name in the encoder like this:
    rtmp://[wowza-ip]:1935/[app-name]/mp4:[streamname]
    Again, sorry for telling you the wrong information.

    Salvadore

Similar Threads

  1. unwanted flv files
    By rochre in forum General Forum
    Replies: 9
    Last Post: 03-03-2014, 03:58 PM
  2. wowza constantly writes to log when it publishes empty stream
    By misha.nesterenko in forum Server-side Modules and Code Samples Discussion
    Replies: 6
    Last Post: 08-19-2013, 06:50 AM
  3. how to play .flv files instead of .mp4 files in wowza from flash player
    By malarprathap in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 08-07-2012, 04:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •