Results 1 to 4 of 4

Thread: Empty Video output despite active stream

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Oct 2014

    Default Empty Video output despite active stream


    We have an issue setting up a new live feed from an Axis Q6045-E on our Wowza server. Our Wowza connects to the RTSP stream from the Axis. However, we are not seeing any output from the live stream in the Wowza test player on in Flowplayer. The Wowza test player states that the video is playing but the screen is black. Flowplayer just shows the loading image perpetually. I've also tried recording the live stream but the recording is empty.

    The Axis camera is behind a firewall. We have been informed that the firewall is open to our Wowza server's IP address using port 554. As mentioned, Wowza is able to connect to the stream as it appears as active.

    I have not had any luck opening RTSP input in VLC (VLC would crash each time I tried to open the stream). However, the IT team who manages the firewall claim they were able to successfully open the RTSP output in VLC both inside and outside the firewall.

    I have tried changing the video quality, compression, and GOV settings for our streaming profile but it does not have any impact. Below is the RTSP address we are using:


    Any one have any ideas on what could be going on here? I suspect the firewall, but IT claims it is open to our server and the stream shows as "Active" in Wowza.

    Thanks for any help!

  2. #2
    Join Date
    Jun 2011


    The real key is to be able to access the stream from VLC from your particular location.
    In VLC try switching between transports (Tools->Preferences->Input/Codecs->Live555 Transport
    HTTP default or RTP over RTSP (TCP)
    See if one of those helps playback in VLC.

    Generally access to UDP packets can be the problem with similar cameras, if some UDP ports are not open
    then similar problems to this could occur.
    Additionally, take a look at the ports that are open at the Wowza server and the firewall. There is a port guides here.


  3. #3
    Join Date
    Oct 2014


    Thanks Darren. I was able to open the RTSP input outside the firewall in VLC. I disabled RTP over RTSP (TCP) and that did the trick. The video would not play in VLC when RTP over RTSP (TCP) was enabled.

    In the Virtual Host Setup, the only two ports enabled were 1935 for streaming and 8086 for admin. I enabled the UDP TCP ports 6970-9999 and RTSP 554 but to no avail. Nothing comes up in the Wowza test player and in flowplayer I still see the spinning circle---
    Last edited by ReefCam; 10-02-2014 at 07:43 AM.

  4. #4
    Join Date
    Oct 2014


    I finally fixed the issue (see the Cornell BirdCam at

    I had to change the rtpTransportMode under the RTSP properties for the stream file from the default (UDP) to RTP. This solved the issue. My guess was that the firewall was blocking the UDP ports. By not using UDP we avoided being blocked on those ports. However, I'm not sure if this was exactly the reason.

    I had the idea to change the rtpTransportMode based on these threads.

Similar Threads

  1. High-availability cluster Active/Active for video-chat application
    By in forum General Forum
    Replies: 1
    Last Post: 09-19-2014, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts