Results 1 to 8 of 8

Thread: Invalid audio codec for iPhone/iPod:SPEEX

  1. #1

    Question Invalid audio codec for iPhone/iPod:SPEEX

    Hi!

    We use Wowza 4.1.6. I enable Transcoder AddOn and configured application using this article

    On log still:

    WARN	server	comment	2014-10-03	18:34:12	-	11.013	-	CupertinoPacketHandler.handleHolder[cams/_definst_/stream_name]: Invalid video/audio codec combination for iPhone/iPod: video:H264 audio:SPEEX
    WARN	server	comment	2014-10-03	18:34:12	-11.013	-CupertinoPacketHandler.handleHolder[cams/_definst_/stream_name]: Invalid audio codec for iPhone/iPod:SPEEX
    Can you explain why appear this warnings?

  2. #2

    Default

    Hello,

    Can you please confirm you are playing the transcoded stream, and not the source stream when getting these errors?

    Thank you,

    Salvadore

  3. #3

    Default

    Hi,

    This errors appears when i publish stream, before playing.

    Thanks for reply!
    Last edited by headshrinker; 10-06-2014 at 06:28 AM.

  4. #4

    Default

    Are you using the template named audioonly.xml in the Wowza /transcoder/templates folder. Use that template as a starting place. The name is a little misleading, it just means that it only transcodes the audio, not the video. The video is set to PassThru. That is the Transcoder template that is used in that article. Start with that, test it as-is before making changes.

    Thank you.

    Salvadore

  5. #5

    Question

    Yes, i'm using audioonly.xml. In wowzastreamingengine_error.log :
    Invalid video/audio codec combination for iPhone/iPod: video:H264 audio:SPEEX
    Invalid audio codec for iPhone/iPod:SPEEX
    Can these errors appears because in some streams audio was set Passthrough(though it not so)?

    Maybe not pay attention to these warnings?

  6. #6

    Default

    The audio will not be transcoded if set to Passthrough. I suggest using the audioonly.xml template as is, without modification, and see if that works.

    If you are only streaming to Flash clients then you can disable cupertinostreamingpacketizer from the <LiveStreamPacketizers> list.

    Salvadore

  7. #7

    Default

    Quote Originally Posted by salvadore View Post
    The audio will not be transcoded if set to Passthrough. I suggest using the audioonly.xml template as is, without modification, and see if that works.
    If I use audioonly.xml without modification it works, but in logs there are warnings.

    Thanks!

  8. #8
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi,

    When a stream is published to Wowza, it also becomes available for playback at Wowza output. In addition to this stream, if you also have the Transcoder addon enabled, the transcoded stream will also become available at Wowza output after it has been transformed by the Transcoder.

    The warnings you are talking about are referring to the un-transcoded stream. Since your source is using Speex audio codec, the warning message is informing you that this particular stream is not supported by iOS devices since they do not support this audio codec.
    You should't get messages related to the transcoded stream.

    Zoran

Similar Threads

  1. audio choppy on iphone/ipod
    By soonsoon in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 08-22-2012, 10:37 AM
  2. Question about video/audio in regards to audio codec switch
    By confusedUser in forum AddOn: Transcoder
    Replies: 1
    Last Post: 08-16-2012, 01:19 PM
  3. strange latency problem when using speex codec
    By jiwan2004 in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 04-10-2012, 06:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •