Results 1 to 6 of 6

Thread: tryConnect set to true by default

  1. #1

    Default tryConnect set to true by default

    This is frustrating as it is creating thousands of open and wait connections. It is also causing the liverepeater edge randomly to freeze up as it attempts to reconnect to hundreds of streams that have since gone off air. I've successfully set the tryConnect to false under certain scenarios (such as onStreamCreate) but have found no other way to do so without throwing an exception. Which results in hundreds of streams trying to reconnect to their origin servers at what appear to be 12 second intervals. Our code internally handles the live/off air status of streams and does not need this auto reconnect feature. What can we do to fully disable this within the server?

  2. #2
    Join Date
    Sep 2011


    If you're using a Live Edge application (StreamType liverepeater-edge) with a regular live application as the origin, the streams are only requested from the origin when a client requests them from the edge.
    When no clients are connected to the edge it does not make or maintain any connection to the origin.

    If no clients are viewing on the edge the stream is destroyed between the origin and edge and requested only when a client connects and tries to play the stream.
    Please see more in the How to configure a live stream repeater article

    Can you be more specific as to how you've configured the origin and edge applications.


  3. #3


    This issue happens with clients that connected to a live stream that has since gone offline. Our design makes it where the client is immediately dropped if the channel is offline (done internally by our own code.) Our code works as intended, but those that connect to a live stream that then goes offline seem to trigger these tryConnect events.

    If you could tell us how to disable these tryConnect events that would be great!

  4. #4



  5. #5


    Surely someone has the answer. The edge servers are basically ddosing my ingest servers because of this bug in wowza.

  6. #6


    *sighs* considering the money I pay just to use the wowza software, you'd think I'd get an answer by now!

Similar Threads

  1. Replies: 0
    Last Post: 12-28-2011, 03:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts