Results 1 to 9 of 9

Thread: RTMP Kulabyte Haivision authentication

  1. #1
    Join Date
    Apr 2013
    Posts
    28

    Default RTMP Kulabyte Haivision authentication

    Hello,
    i own a Kulabyte Haivision encoder, i have an issue when i enable ModuleRTMPAuthenticate in the xml application file.
    When i enable the module the encoder cant connect to the wowza media server and when is disabled the connection established .
    Let me know if there is some issue where it is not working properly with Kulabyte encoders.

  2. #2

    Default

    Hello there,

    First, can you confirm you are entering the publisher name and password correctly when ModuleRTMPAuthenticate is enabled?

    Second, you could try adding the name of the encoder to the Flash Version String field.
    If you are not sure what to put here, you can find it by looking for a line like this in the logs:
    INFO server comment 2011-01-14 22:16:23 - - - - - 2.894 - - - - - - - - Flashver: Wirecast/FM 1.0 (compatible; FMSc/1.0)
    You can edit this field at:
    Engine Manager > App name > Incoming Security > Flash Version String
    And here is the guide for further reference:
    How to configure security using Wowza Streaming Engine Manager

    Lastly, are you seeing any indication of the issue output to the Wowza logs? You can start Wowza in stand-alone mode [install-dir]/bin/startup.bat|startup.sh and view the output in the console. Or you can find the logs at [install-dir]/logs

    Thank you,

    Salvadore

  3. #3
    Join Date
    Apr 2013
    Posts
    28

    Default

    Hello,
    1. The publish name and password are correct i use an other FMLE encoder to connect and everything is OK
    2. Adding the name of the encoder to the Flash Version String field. Is there any other module i cant find this line into Application.xml
    How can do that with Wowza Media Server 3 Perpetual Edition 3.6.3
    3. From logs
    2014-10-14 11:56:53 EEST connect-pending session INFO 100 ........ Kulabyte (compatible; FMSc/1.0)

    Thank you.

  4. #4

    Default

    In Wowza 3.x, you need to add the "AllowEncoder" property to the Application.xml /Properties list, at bottom of the file:
    <Property>
    	<Name>AllowEncoder</Name>
    	<Value>FM</Value>
    </Property>
    "FM" should work as the userAgent of the encoder, if not, look in the access log and you should see the userAgent of the encoder. Copy that to the AllowEncoder Property Value.

    Thank you,

    Salvadore

  5. #5
    Join Date
    Apr 2013
    Posts
    28

    Default

    No it doesnt work for me, i also tryied http://www.wowza.com/forums/showthre...oders-in-wowza but i cant connect .

  6. #6

    Default

    Please restart Wowza and try to publish again, then zip up conf and logs folders and send to support@wowza.com

    Tell us which application you are using, and any custom code you may have.

    Include the connection URL you are using in the encoder

    Include a link to this thread for reference.

    Thank you,

    Salvadore

  7. #7

    Default

    Actually, before you open a ticket, have you read through this article carefully?
    How to enable username/password authentication for RTMP and RTSP publishing

    Salvadore

  8. #8
    Join Date
    Apr 2013
    Posts
    28

    Default

    FYI Kulabyte Haivision mention ,that the connection to Wowza should be Open. No authentication required under Incoming Security, so i used the ModuleSecureURLParams module
    http://www.wowza.com/forums/content.php?233 and works fine for me.

    Thank you

  9. #9

    Default

    Thank you for the update, and I am glad to hear you got this sorted.

    Salvadore

Similar Threads

  1. Haivision Makito RTMP
    By pirateMan in forum Live Streaming and Encoders
    Replies: 7
    Last Post: 03-22-2016, 08:24 AM
  2. RTMP authentication, RTSP authentication => problem
    By nvanhaute1 in forum Server Administration Discussion
    Replies: 4
    Last Post: 11-09-2011, 03:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •