Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Call Wowza web service not success.

  1. #1
    Join Date
    Nov 2014
    Posts
    13

    Default Call Wowza web service not success.

    I use Wowza server and develop by C#.
    I need to call the Wowza web service.
    I follow the step of "How to add a web service interface to Wowza Media Server and integrate with .NET (dotNet)".
    But it's not work,
    I think i need a more detailed process.

  2. Default

    What Wowza webservice are you referring to? Wowza has some XML-formatted information available via the admin host port (8086), like /connectioncounts and /serverinfo. If you're able to call these from a standard web browser (e.g. http://my-wowza-ip:8086/serverinfo), then you should be able to reach them from you code too.

    NB! These "web services" require DIGEST authentication. You must set a username and password in the /conf/admin.password file (this is done at installation with version 4.x, with version 3.x you must do it manually). Remember to implement DIGEST auth in your .NET code.

  3. #3
    Join Date
    Nov 2014
    Posts
    13

    Default

    Thinks karelboek!
    I Get the Wowza infomation by this web service,
    And How if I want to upload the file to my Wowza server by my C# Project.
    What should I do?
    Is there any C# project can provide me with a reference?

  4. Default

    Wowza does not provide any functions for file transfer. If you want to upload files to your Wowza server, you should look into the usual file transfer options that your server offers, e.g. FTP or maybe HTTP with Content-Range. Make sure the files end up in the /content folder of your Wowza installation, or the folder that you defined as the Content Directory in your Wowza VOD application. There are numerous C# samples of uploading files to a server (Just use Google)

  5. #5
    Join Date
    Nov 2014
    Posts
    13

    Default

    OK! karelbeok
    I'm so Junior.
    I still need to ask,
    If that my file on Wowza Server is mpeg,
    and I was assigned to write the streaming player.
    how can I playback the video on Wowza Server?
    Is there any process or sample that I can follow?

  6. #6
    Join Date
    Nov 2014
    Posts
    13

    Default

    I just try to playback the sample video on my server by using the "http://www.wowza.com/testplayers".
    But I fail.
    There has a message say's "The video could not be loaded, either because the server or network failed or because the format is not supported. - See more at: http://www.wowza.com/testplayers#sthash.61TzytAi.dpuf".
    My system architecture like this:
    I install Wowza server on A test server, and Browse the "http://www.wowza.com/testplayers" webite with the B computer.
    I already turn off the firewall of B computer.
    what kind of problem might i have?

  7. Default

    You can see all Wowza tutorials on http://www.wowza.com/forums/content.php?4-tutorials. Try first to play the sample.mp4 file that comes with the installation, before you test with your own content.

  8. #8
    Join Date
    Nov 2014
    Posts
    13

    Default

    Hello! karelboek
    I already can playback the video on A test server.
    What if I want to browse the "http://www.wowza.com/testplayers" webite with the B computer to watch my video,
    what tutorial do I need to read?
    The Wowza Server is to powerful and the tutorials is to many,
    can you list to me?

  9. Default

    This is basic Wowza stuff, and doesn't have much to do with your original request about consuming Wowza web services in .NET. From the Wowza test players page, you must put in the IP address (or DNS name), and the port (default 1935) of your server A to start playing. Make sure your computer B and server A can talk to each other (test with e.g. ping) and that the required port(s) are open on the firewall, if there's any.

  10. #10
    Join Date
    Nov 2014
    Posts
    13

    Default

    karelboek!
    I find the problem!
    The firewall on Server A is turn on, So I can't access the Wowza server.
    For test, I turn the firewall off, and it's work.
    I will keep try rest of part.
    Thanks for you support.

Page 1 of 2 12 LastLast

Similar Threads

  1. web service accessibility on trial version?
    By SFGMedia in forum General Forum
    Replies: 6
    Last Post: 10-18-2013, 09:15 AM
  2. Web Service Calls
    By DaveSanDiego in forum Server-side Modules and Code Samples Discussion
    Replies: 1
    Last Post: 04-01-2013, 12:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •