Results 1 to 4 of 4

Thread: Wowza and Flowplayer mp4 files no video only audio

  1. #1

    Default Wowza and Flowplayer mp4 files no video only audio

    Hello, I have a wowza server to play VOD files, it plays them well (m4v files). I added new mp4 files to the server, the player streams audio only. I don't know why!!

    Player code:

    <script>
    		    // install flowplayer into container
    		    $f("video", "flowplayer/flowplayer/flowplayer.swf", {
    		        plugins: {
    		            rtmp: {
    		            url: 'flowplayer.rtmp-3.1.3.swf',
    		                netConnectionUrl: 'rtmpe://server-ip:1935/videos',
    
    		                // make the rtmp plugin query the stream length from the server 
    		                durationFunc: 'getStreamLength'
    		            },
    		            controls: {
    		                fullscreen: false,
    		                height: 30,
    		                buttonColor: '#B72E00',
    		                buttonOverColor: '#842100',
    		                backgroundColor: '#FF9900',
    		                timeColor: '#FFFFFF',
    		                durationColor: '#FFFFFF'
    		            }
    		        },
    		        clip: {
    		            // it's possible to stream audio by using the RTMP plugin 
    		            provider: 'rtmp',
    		            autoPlay: false
    		        }
    		    });
    </script>
    
    <div id="video" style="display:block;width:900px;height:400px;color:Green" href="mp4:high/test.mp4">Play</div>

  2. #2

    Default

    What is the video codec of these files?

    Do you see any indication of an issue in the logs?

    Kind regards,

    Salvadore

  3. #3

    Default

    Quote Originally Posted by salvadore View Post
    What is the video codec of these files?

    Do you see any indication of an issue in the logs?

    Kind regards,

    Salvadore
    Some files give me this error:
    File is missing 'moov' atom.

    and some this error:
    java.io.FileNotFoundException
    But the file is there

  4. #4

    Default

    server    WARN    404    [path-to-video-file]     MediaReaderH264.open[2]: java.lang.Exception: QTUtils.parseQTMediaContainer: File is missing 'moov' atom.
    Cause: An attempt was made to stream a file while it's being recorded. When the stream is unpublished, Wowza Media Server writes the moov atom data to the end of the file. You can use the IMediaWriterActionNotify listener to listen for files to be completed. If you use the nDVR AddOn, then you can record while playing back a live stream.

    You may also get this error if you try to playback a file that has H.264 content but isn't an mp4 file and you use the mp4 prefix. For example, you published H.264 video from your encoder and Wowza Media Server recorded it as an FLV file. If you use the mp4 prefix in this case, you'll get this error. The correct way is to treat the file as a standard FLV file.

    Sounds like you have .flv files and trying to stream them as .mp4. You could try to prefix the file name flv:fileName.flv. If your clients are flash only, this should work(If the files are actually .flv)

    mp4 uses H.264 video, and AAC or mp3 audio. So to stream to non-Flash clients you will need to re-encode the files. Here is a guide for that:
    How to encode video on demand content

    Kind regards,

    Salvadore

Similar Threads

  1. No Video in the recorded MP4 files
    By mahesh123 in forum General Forum
    Replies: 2
    Last Post: 05-02-2014, 01:45 PM
  2. how to play .flv files instead of .mp4 files in wowza from flash player
    By malarprathap in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 08-07-2012, 04:56 AM
  3. Replies: 0
    Last Post: 06-18-2012, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •