Results 1 to 4 of 4

Thread: DVC camera stream

  1. #1

    Default DVC camera stream

    I use Wowza for some time and I had no major problems. The whole system is based on Vivotek cameras and running fine. Now I'm trying to set an IR bullet camera, Model DVC-CAMN-OC533-1080P-IR-DN.
    In the camera network configuraton -> RTSP, I enabled RTSP server and added port 9009 and in Wowza -> Content ->, I wrote an rtsp: // 9009 / profile1 (from camera config).
    When I try to connect with VLCPlayer, locally connects but requires a username and password. I run stream in Wowza but when I try to connect with VLCPlayer through Wowza stream, does not work. I tried to run, and from the website JWPlayer. Does not work.
    Does anyone have experience or advice?

  2. #2


    Hello there.

    Please be sure to follow this guide:
    How to re-stream video from an IP camera (RTSP/RTP re-streaming)

    If the camera is setup to require authentication you can add the username and password to the URL in the .stream file like this:
    Also, you can check the logs for any errors or warnings to see if you can track down the issue. To start Wowza in stand alone mode, and view the output in the console use [install-dir]/bin/startup.bat

    This guide aids in troubleshooting:
    How to troubleshoot RTSP/RTP playback

    I hope this helps.

    Kind regards,


  3. #3


    I turned off password protection, and now the VLC will connect without a password. In the .stream file I enrolled rtsp://[camera-address]:9009/profile1. Vivotek cameras have the address rtsp://[camera-address]/live.sdp. Looks like I did not write good in .stream file but can't find in the documentation camera accurate data.
    In the JW Player I put the address of Wowza stream rtmp://[Wowza server-address]/[stream-group]/[camera].stream, and Vivotek cameras in this way works. DVC is not working!


  4. #4
    Join Date
    Jun 2011


    You could try changing TransportMode to udp (in the properties->rtsp properties of the Stream File you created.
    Some cameras will only stream using UDP, while others need interleave or both.
    You could try adding RTSP debugging to the logs by adding the RTSP debug property.
    That will add the SDP communication to the access logs, and some useful messages. You can paste snippets of the [install-dir]/*access.log logs here.


Similar Threads

  1. What IP camera should I use in order to publish audio back to the camera
    By mwallace in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 06-03-2014, 09:34 AM
  2. Video Chat Multiple Camera Not Streaming For Second Camera
    By emreVeriyaz in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 06-01-2012, 02:39 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts