Results 1 to 2 of 2

Thread: Null Pointer Exception when trying to play nDVR from smil

  1. #1

    Default Null Pointer Exception when trying to play nDVR from smil

    Hi Guys,

    I am having a wierd problem with nDVR recordings. When I play the nDVR using the smil file like this:

    http://XXX.XXX.XXX.XXX:80/SVcatchup/...ylist.m3u8?DVR

    Wowza gives an Null Pointer error like below:

    2014-12-10 16:03:42 CET comment server ERROR 500 - HTTPStreamerAdapterCupertinoStreamer.onPlaylist: java.lang.NullPointerException|at com.wowza.wms.dvr.impl.DvrStartDurationPlaylistRequestDelegate.a(DvrStartDurationPlaylistRequestDele gate.java:192)|at com.wowza.wms.dvr.impl.DvrStartDurationPlaylistRequestDelegate.a(DvrStartDurationPlaylistRequestDele gate.java:180)|at com.wowza.wms.dvr.impl.DvrStartDurationPlaylistRequestDelegate.a(DvrStartDurationPlaylistRequestDele gate.java:151)|at com.wowza.wms.dvr.impl.DvrStartDurationPlaylistRequestDelegate.getDvrPlaylistRequest(DvrStartDuratio nPlaylistRequestDelegate.java:95)|at com.wowza.wms.dvr.DvrPlayerAdapterBase.getDvrPlaylistRequest(DvrPlayerAdapterBase.java:425)|

    The smil file contains the following:

    <smil>
    <head>
    </head>
    <body>
    <switch>
    <video src="mp4:9-226750_720p" system-bitrate="1596000" width="640" height="360">
    </video>
    <video src="mp4:9-226750_360p" system-bitrate="896000" width="640" height="360">
    </video>
    <video src="mp4:9-226750_240p" system-bitrate="396000" width="640" height="360">
    </video>
    </switch>
    </body>
    </smil>

    But if I try to play each of the stream in the smil file manually, it plays alright. Like for example if I do http://XXX.XXX.XXX.XXX:80/SVcatchup/...ylist.m3u8?DVR it plays without a problem.

    Can someone explain where this error might be coming from?

    Regards,

  2. #2

    Default

    Hello there,

    For the quickest, most efficient troubleshooting assistance, please open a ticket with the support team. To do so please zip the following folders and sent them, along with the .smil file and a link to this thread for reference to support@wowza.com:
    [install-dir]/conf
    [install-dir]/logs
    [install-dir]/transcoder
    [install-dir]/manager/logs


    Thank you.

    Salvadore

Similar Threads

  1. Null Pointer Exception on enabling of an Encode
    By RobertSLAB in forum Wowza Transcoder
    Replies: 2
    Last Post: 10-31-2014, 11:24 AM
  2. Null pointer exception at com.wowza.wms.stream.live.MediaStreamLive.close
    By anupam in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 07-21-2014, 02:43 AM
  3. null pointer exception in logs
    By trutwijd in forum AddOn: Transcoder
    Replies: 2
    Last Post: 10-10-2013, 11:52 AM
  4. nDVR Exception
    By ozgurdeniz in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 04-09-2013, 07:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •