Results 1 to 4 of 4

Thread: Transcoder stops at 3 hours

  1. #1
    Join Date
    Jul 2013
    Posts
    4

    Default Transcoder stops at 3 hours

    Hello,
    Our self hosted Wowza Streaming engine server live stream transcoder is stopping after exactly 3 hours even with clients connected to the stream. We are using the transrate template. The live source (other encoder) is still up and running and Wowza logs the transcoder stop of all video and audio streams after x-duration of 65859.3xx. I didn't see any time limits in the streaming engine manages. Where else should I check?

    We are running Engine Version
    4.1.1 (build 13180)
    Engine Manager Version
    4.1.1 (build 13180)
    License
    Wowza Streaming Engine 4 Perpetual Bundle Edition

    Thanks,
    Mike

  2. #2
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    There aren't any such time limits. Exactly 3 hours does seem suspicious though.
    Do you see any significant messages in the error logs or access logs, located at [install-dir]/logs/wowzastreamingengine_access.log
    or wowzastreamingengine_error.log around the time it stops?

    Daren

  3. #3
    Join Date
    Jul 2013
    Posts
    4

    Default

    Daren,
    After further review of the logs the issue happens at 2 hours and not 3. Also we were able to reproduce the issue without running the transcoder and with 2 different encoders, FFMpeg, and an Epiphan DVI Broadcaster DL . The Wowza logs show an orderly shutdown of the session even though the encoders were still running. It seems to be a firewall issue when sending the RTSP stream from the encoder to the Wowza server using UDP. With RTSP over TCP the encoder streams stay up as expected and our issue is solved. With FFMpeg we added "-rtsp_transport tcp" to the output command, and with the Epiphan there is a checkbox “Use TCP for RTP stream”.

    Thanks,
    Mike

  4. #4
    Join Date
    Jun 2011
    Posts
    1,037

    Default

    Hi,
    Glad you have that resolved. If you do need to use UDP you'll need to open a range of such ports.
    This guide section talks about what to open.

    Daren

Similar Threads

  1. Transcoder stops unexpectedly
    By jsoberan in forum Wowza Transcoder
    Replies: 1
    Last Post: 06-23-2014, 05:02 AM
  2. Transcoder stops after approximately one hour
    By petabyte in forum Wowza Transcoder
    Replies: 4
    Last Post: 06-16-2014, 02:35 PM
  3. WOWZA Service Stops when logging off from the Server & after long hours of idle time
    By sgopalkr in forum Server Administration Discussion
    Replies: 14
    Last Post: 04-02-2013, 08:45 AM
  4. Thread dies in a few hours
    By erlik28 in forum General Forum
    Replies: 2
    Last Post: 11-27-2012, 02:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •