Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Please help this is driving me nuts! Keep receiving out of memory error

  1. #1

    Default Please help this is driving me nuts! Keep receiving out of memory error

    Hi can someone please help i hope ive posted this in the right section as this is driving me nuts,
    I keep receiving this error: Exception in thread "Thread-351" java.lang.OutOfMemoryError: Java heap space

    Now ive done some research and was told to go into the setenv.bat file and edit the set JAVA_OPTS=-Xmx760M

    Now ive read where it says to edit it depending on your memory etc but i have 64gb of ram and i can only edit the set JAVA_OPTS=-Xmx1650M part with that amount of memory as otherwise if i put more in than 1650 and click startup it doesnt load at all.

    Any ideas?

    this is the the cmd that froze:

    Exception in thread "VHostHandler._defaultVHost_.93" java.lang.OutOfMemoryError:
     Java heap space
            at com.wowza.wms.request.RequestProcessData.processNextRequest(Unknown S
    ource)
            at com.wowza.wms.client.ClientWorker.processNextReq(Unknown Source)
            at com.wowza.wms.request.RTMPRequestAdapter.service(Unknown Source)
            at com.wowza.wms.server.ServerHandler.serviceRequest(Unknown Source)
            at com.wowza.wms.server.ServerHandler.handleMessageReceived(Unknown Sour
    ce)
            at com.wowza.wms.server.ServerHandler.messageReceived(Unknown Source)
            at com.wowza.wms.server.ServerHandlerThreadedSession.run(Unknown Source)
    
            at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
    Exception in thread "Thread-229" java.lang.OutOfMemoryError: Java heap space
            at java.util.jar.Manifest$FastInputStream.<init>(Unknown Source)
            at java.util.jar.Manifest$FastInputStream.<init>(Unknown Source)
            at java.util.jar.Manifest.read(Unknown Source)
            at java.util.jar.Manifest.<init>(Unknown Source)
            at java.util.jar.JarFile.getManifestFromReference(Unknown Source)
            at java.util.jar.JarFile.getManifest(Unknown Source)
            at sun.misc.URLClassPath$JarLoader$2.getManifest(Unknown Source)
            at java.net.URLClassLoader.defineClass(Unknown Source)
            at java.net.URLClassLoader.access$100(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.net.URLClassLoader$1.run(Unknown Source)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at java.lang.ClassLoader.loadClass(Unknown Source)
            at org.apache.mina.transport.socket.nio.SocketIoProcessor$Worker.run(Unk
    nown Source)
            at org.apache.mina.util.NamePreservingRunnable.run(Unknown Source)
            at java.lang.Thread.run(Unknown Source)
    Exception in thread "Thread-228" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "serverWatchdog" Exception in thread "vhostWatchdog" java.la
    ng.OutOfMemoryError: Java heap space
    java.lang.OutOfMemoryError: Java heap space
    Exception in thread "Thread-351" java.lang.OutOfMemoryError: Java heap space
    Exception in thread "Thread-4" java.lang.OutOfMemoryError: Java heap space

  2. #2

    Default

    Also im getting this error a hell of alot:

    ERROR server comment - Zero sized function (client:418683:FMLE/3.0 (compatibl
    e; FMSc/1.0)): type:20 size:0


    Also this error:

    java.lang.OutOfMemoryError: GC overhead limit exceeded

  3. #3

    Default

    Hello. It is possible this is going to require you to open a ticket to resolve.

    But before I suggest that, let me point out the Performance Tuning Guide
    Please make sure your server is tuned as per these specifications.

    If tuned and you still have this problem, the support team will need you to produce a heap dump. Directions to do so can be found here:
    How to take a Java heap dump

    Please follow these directions the next time this happens and zip it up along with your /conf and /logs folders and send them to support@wowza.com. Also mention Wowza version, any custom modules or configurations and a link to this thread as a reference.

    Kind regards,

    Salvadore

  4. #4

    Default

    Here is my setenv.sh file well the 1st part of it anyway

    @echo off
    
    set _EXECJAVA=java
    set JAVA_OPTS=-Xmx10000M
    
    rem If running JDK, uncomment to run server environment (faster)
    rem set JAVA_OPTS=%JAVA_OPTS% -server
    
    rem Better garbage collection setting to avoid long pauses
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=4096m
    
    rem Uncomment to fix multicast crosstalk problem when streams share multicast port
    rem set JAVA_OPTS=%JAVA_OPTS% -Djava.net.preferIPv4Stack=true


    Is that right to have it like that or should it be like this:

    @echo off
    
    set _EXECJAVA=java
    set JAVA_OPTS=-Xmx10000M
    
    rem If running JDK, uncomment to run server environment (faster)
    set JAVA_OPTS=%JAVA_OPTS% -server
    
    rem Better garbage collection setting to avoid long pauses
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=4096m
    
    rem Uncomment to fix multicast crosstalk problem when streams share multicast port
    rem set JAVA_OPTS=%JAVA_OPTS% -Djava.net.preferIPv4Stack=true
    As this page here http://www.wowza.com/forums/content....ormance-Tuning says to put the setenv.sh file like this:
    set JAVA_OPTS=%JAVA_OPTS% -server
    but mine is like this
    rem set JAVA_OPTS=%JAVA_OPTS% -server
    So im not sure

  5. #5

    Default

    Hi, I see you have your Java Heap Size set at 10,000MB. It is recommended for a Heap Size of 8,000MB with 16 GB of RAM.

    Also yes, you might try un-commenting JAVA_OPTS=%JAVA_OPTS% -server. So:
    set JAVA_OPTS=%JAVA_OPTS% -server

    Kind regards,

    Salvadore

  6. #6

    Default

    Quote Originally Posted by salvadore View Post
    Hi, I see you have your Java Heap Size set at 10,000MB. It is recommended for a Heap Size of 8,000MB with 16 GB of RAM.

    Also yes, you might try un-commenting JAVA_OPTS=%JAVA_OPTS% -server. So:
    set JAVA_OPTS=%JAVA_OPTS% -server

    Kind regards,

    Salvadore
    Hi thanks for the reply i have tried un commentating what u said and i saw u said it is recommended for a heap size of 8000MB with 16GB of Ram,
    I currently have 64GB of ram so what would be the current figure to input there then?

  7. #7

    Default

    The Tuning Guide says to not exceed 10,000 MB, but recommends 8,000 for 16 GB for RAM or higher. So you are maxed at 10 GB. You might try dialing it down to see if that helps.

    Also:
    Wowza strongly recommends No Additional Settings. The default -server tuning (see step #2 above) works well for many streaming situations, so in most cases this tuning works great without additional settings.
    This is an advanced GC setting, although in your post this is commented out:
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=4096m

    But it should not be set any higher then 512m
    If heap size is 5000 MB or greater, NewSize=512m

    You might want to double check your settings against this guide. Be sure you look everything over closely.

    Kind regards,

    Salvadore

  8. #8

    Default

    Quote Originally Posted by salvadore View Post
    The Tuning Guide says to not exceed 10,000 MB, but recommends 8,000 for 16 GB for RAM or higher. So you are maxed at 10 GB. You might try dialing it down to see if that helps.

    Also:


    This is an advanced GC setting, although in your post this is commented out:
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=4096m

    But it should not be set any higher then 512m
    If heap size is 5000 MB or greater, NewSize=512m

    You might want to double check your settings against this guide. Be sure you look everything over closely.

    Kind regards,

    Salvadore
    So Just to be sure i have got this right this is what it should look like:

    @echo off
    
    set _EXECJAVA=java
    set JAVA_OPTS=-Xmx8000M
    
    rem If running JDK, uncomment to run server environment (faster)
    set JAVA_OPTS=%JAVA_OPTS% -server
    
    rem Better garbage collection setting to avoid long pauses
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=512m
    
    rem Uncomment to fix multicast crosstalk problem when streams share multicast port
    rem set JAVA_OPTS=%JAVA_OPTS% -Djava.net.preferIPv4Stack=true

    What does the "rem" at the start of those lines mean exactly?
    For
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=512m
    Would it be better to remove the "rem" from the start

    Thanks for helping by the way as id be lost if u didnt help

  9. #9

    Default

    Yes, I think that is looking more appropriate.

    You will need to restart the server for these edits to take affect.

    "rem" is a comment, meaning the code or documentation that follow is deactivated. Or "human-readable" only. These lines will be ignored by the machine and are an aid in documenting code.

    Removing the comment tag "rem" would activate the settings, so I don't think you want to do that at this point.

    You are welcome, I hope this helps with your problem. If not, please refer back to my suggestion for opening a ticket.

    Kind regards,

    Salvadore

  10. #10

    Default

    Quote Originally Posted by salvadore View Post
    Yes, I think that is looking more appropriate.

    You will need to restart the server for these edits to take affect.

    "rem" is a comment, meaning the code or documentation that follow is deactivated. Or "human-readable" only. These lines will be ignored by the machine and are an aid in documenting code.

    Removing the comment tag "rem" would activate the settings, so I don't think you want to do that at this point.

    You are welcome, I hope this helps with your problem. If not, please refer back to my suggestion for opening a ticket.

    Kind regards,

    Salvadore
    So rem basically means stopping the setting from activating? so if i wanted a setting to activate then i would always need to remove the rem right?

    With this
    rem set JAVA_OPTS=%JAVA_OPTS% -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:NewSize=4096m
    wouldnt removing the rem activate the setting then cause isnt that what i want it to anyway have it activated?

Page 1 of 2 12 LastLast

Similar Threads

  1. Receiving an already-encrypted stream?
    By Fireblend in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 10-05-2014, 01:25 PM
  2. Java Out of memory error
    By rezilient in forum General Forum
    Replies: 7
    Last Post: 02-18-2014, 11:00 AM
  3. Origin memory error with GC
    By asherly7 in forum General Forum
    Replies: 7
    Last Post: 11-06-2011, 11:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •