Results 1 to 3 of 3

Thread: FMLEcmd cannot reconnect to Wowza after interruption

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default FMLEcmd cannot reconnect to Wowza after interruption

    Dear Wowza support team,

    we currently use an Adobe FMLE 3.2 Encoder Command Line Interface (FMLECmd.exe) on Windows to publish a Livestream to our Wowza Streaming Engine 4.1.0 build12602.

    The live publishing point is configured in a way that it requires RTMP and RTSP authentication for incoming streams.

    We pass the credentials to the FMLE in the following way:

    "C:\Program Files\Adobe\Flash Media Live Encoder 3.2\FMLECmd.exe" /p "livestream.xml" /ap usernameassword

    However it happens from time to time that the FMLEcmd.exe publishing to the primary (Wowza) server gets disconnected, and after that it cannot reconnect to the streaming server.
    If we manually close the console window and restart the FMLEcmd.exe command, a new connection with credentials is established without any problems.

    I assume that the authentication credentials in the FMLEcmd.exe are only applied for a single stream session and not for the entire encoding session.

    Do you know any workaround on how to re-establish a lost RTMP push stream connection within the FMLEcmd.exe?

    Or is there any known issue on the Wowza Streaming Engine that it loses an incoming authenticated RTMP connection from time to time? Because the strange thing is that we obviously had continuous internet access during this issue occurence but Adobe Flash Media Encoder nevertheless reported a "connection closed" message.

    Thanks for every suggestion.


  2. #2


    Hi Andre,

    Running Wowza in stand-alone mode may uncover some helpful information on what is happening around the time of the disconnection.

    You can restart Wowza with [install-dir]/bin/startup/bat| and view the output in the console.

    There may be something in there to help identify the issue.

    Kind regards,


  3. #3



    Hello, it has come to my attention that has been fixed in the Wowza version 4.1.1

    A word of precaution:
    Be sure to review and follow the upgrade guide:
    Wowza Streaming Engine 4.0 Upgrade Guide

    Latest Production Build

    Let us know if this works for you.

    Kind regards,


Similar Threads

  1. nDVR and stream interruption
    By Priority1 in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 01-07-2016, 10:57 AM
  2. MediaCaster Disconnects After Reconnect
    By Moresheth in forum Server-side Modules and Code Samples Discussion
    Replies: 4
    Last Post: 08-16-2013, 04:24 PM
  3. WOWZ reconnect
    By robstreamhosting in forum General Forum
    Replies: 7
    Last Post: 05-17-2013, 07:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts