Results 1 to 2 of 2

Thread: broken pipe issue

  1. #1
    Join Date
    Dec 2013
    Posts
    18

    Default broken pipe issue

    Hi, Wowza team

    We've had a issue these days, which shows an error at the below.
    comment server ERROR 500 - HTTPByteReader.sendRequest[http://www.cdn.vision.com:8080/.../3801440898288292_960x540_1000k.mp4]: java.net.SocketException: Broken pipe

    I've read the post on the below link, which tells that the issue is because of the problem of the network.
    http://www.wowza.com/forums/showthre...2053#post52053

    Thus, we have already checked the network states at the time the error occurs, but it was not that congested.
    Do you have any idea of this issue? is there any other reason to occur that logs?

    The why we want to know about the answer of this issue is that we have an issue which the clients can't see the VOD on their side during playing.
    As you know, We are using Wowza Server latest 3.x with the latest MediaCache add on

    We suspect that the MediaCache could not succeed the range request so that the Wowza couldn't serve the video the client requested.

    Please answer as soon as possible,
    Thanks in advance


    Sincerely
    Namhun
    Last edited by i5on9i; 02-03-2015 at 06:04 PM.

  2. #2
    Join Date
    Dec 2013
    Posts
    18

    Default

    Hi Wowza team.

    We have checked the origin server logs when the Broken pipe error occurs.
    We can see the below logs, which one is the log of origin server and another is the Wowza edge server.

    In addition to the previous question, We have another question for this logs
    First, is it the normal to have a several HTTP request at the same time?(see wowza server log) in other words, the MediaCache sends several requests to the server at the same time?
    or just is it the re-request because of the failure of the ex-request?



    // wowza server log
    2015-02-04 07:17:48 KST comment server ERROR 500 - MediaCacheHTTPByteReader.sendRequest[http://xxx.com/960x540_1000k.mp4]: java.net.SocketException: broken pipe - - - 2.3485384356E7 - - - - - - - - - - - - - - - - - - - - -
    2015-02-04 07:17:48 KST comment server ERROR 500 - MediaCacheHTTPByteReader.sendRequest[http://xxx.com/960x540_1000k.mp4]: java.net.SocketException: broken pipe - - - 2.3485384487E7 - - - - - - - - - - - - - - - - - - - - -
    2015-02-04 07:17:48 KST comment server ERROR 500 - MediaCacheHTTPByteReader.sendRequest[http://xxx.com/960x540_1000k.mp4]: java.net.SocketException: broken pipe - - - 2.3485384601E7 - - - - - - - - - - - - - - - - - - - - -
    
    
    // file origin server Apache log
    xxx.xxx.xxx.xxx - - [04/Feb/2015:07:17:49 +0900] "HEAD 960x540_1000k.mp4 HTTP/1.1" 200 - "-" "-"
    xxx.xxx.xxx.xxx - - [04/Feb/2015:07:17:49 +0900] "GET 960x540_1000k.mp4 HTTP/1.1" 206 2097152 "-" "-"
    xxx.xxx.xxx.xxx - - [04/Feb/2015:07:17:49 +0900] "GET 960x540_1000k.mp4 HTTP/1.1" 206 728024 "-" "-" 
    xxx.xxx.xxx.xxx - - [04/Feb/2015:07:17:49 +0900] "GET 960x540_1000k.mp4 HTTP/1.1" 206 2097152 "-" "-"

Similar Threads

  1. Broken nDVR
    By ai212983 in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 05-11-2012, 03:30 PM
  2. Broken NDVR
    By patzlaff in forum AddOn: Wowza nDVR
    Replies: 3
    Last Post: 05-11-2012, 12:23 PM
  3. Is cupertinoplaylisthostdomain broken in wms3 ?
    By jay_charles in forum General Forum
    Replies: 2
    Last Post: 01-13-2012, 09:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •