Results 1 to 5 of 5

Thread: Strange recording

  1. #1

    Question Strange recording

    Hi Wowza,

    We use wowza to make recording of live video chats. I noticed one of the flv recordings has a jump of more then a hour in the timecode at 51 second. This probably messes up our ffmpeg conversion of this file
    I used the FLVUtils to debug the flv. (tc = timecode)
    packet[aud]: type:8 seq:0 tc:51044 atc:0 size:11 codec:b isCodecConfig:false
    packet[vid]: type:9 seq:0 tc:51058 atc:0 size:1069 codec:2 isCodecConfig:false isKey:false
    packet[aud]: type:8 seq:0 tc:51064 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51084 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51104 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51124 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51144 atc:0 size:11 codec:b isCodecConfig:false
    packet[vid]: type:9 seq:0 tc:51151 atc:0 size:1121 codec:2 isCodecConfig:false isKey:false
    packet[aud]: type:8 seq:0 tc:51164 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51184 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:51204 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960368 atc:0 size:11 codec:b isCodecConfig:false
    packet[vid]: type:9 seq:0 tc:3960443 atc:0 size:1015 codec:2 isCodecConfig:false isKey:false
    packet[aud]: type:8 seq:0 tc:3960388 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960408 atc:0 size:11 codec:b isCodecConfig:false
    packet[vid]: type:9 seq:0 tc:3960499 atc:0 size:1664 codec:2 isCodecConfig:false isKey:false
    packet[aud]: type:8 seq:0 tc:3960428 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960448 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960468 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960488 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960508 atc:0 size:11 codec:b isCodecConfig:false
    packet[vid]: type:9 seq:0 tc:3960593 atc:0 size:1095 codec:2 isCodecConfig:false isKey:false
    packet[aud]: type:8 seq:0 tc:3960528 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960548 atc:0 size:11 codec:b isCodecConfig:false
    packet[aud]: type:8 seq:0 tc:3960568 atc:0 size:11 codec:b isCodecConfig:false
    How is this possible is it a problem in Wowza or the webcam/Flash?
    What can we do to avoid it this in the future?

    Kind Regards
    Marcel

  2. #2
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    I believe this is caused by the publishing client and can happen when the stream is unpublished and republished without disconnecting.
    As the timecodes are set by the encoder this is not something we can change.

    Regards,
    Jason

  3. #3

    Default

    Hi Jason,

    Thank you for your answer!
    So the problem in probably in the webcam/webcam drive or network and not in our flash app or wowza.

    We record now flv, would it made any difference if we recorded mp4?

    Kind Regards
    Marcel

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    As I said this can be replicated by unpublished and republished without disconnecting the source. Is it possible that this is what happened and it was a user error on the encoder side? Changing the container used for the recording will not make a difference to the outcome if the timecodes are incorrect. You said "This probably messes up our ffmpeg conversion of this file", can you confirm this is the case?
    It may be possible to edit the recording with FFmpeg to resolve this but you would need confirmation as I'm not 100% sure. This question/confirmation (about FFmpeg) is best asked on the FFmpeg forum.

    Regards,
    Jason

  5. #5

    Default

    Hi Jason

    Thanks for you answer.
    Yes, it messes up the conversion. I just wanted to be sure mp4 that didn't fixes it. But I wasn't expecting to be fixed with mp4 recording. Because mp4 must have a timecode.
    Probably I can fix the flv file with FLVUtils. If I write some java code.

    Kind Regards
    Marcel

Similar Threads

  1. Recording audio, a strange out of sync problem
    By jiwan2004 in forum Live Streaming and Encoder Discussion
    Replies: 2
    Last Post: 07-03-2013, 12:49 AM
  2. Strange Warning
    By silver2003tl in forum General Forum
    Replies: 5
    Last Post: 05-04-2012, 02:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •