Results 1 to 10 of 10

Thread: WowzaStreamingEngine not starting with systemd

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default WowzaStreamingEngine not starting with systemd

    I have recently installed WowzaStreamingEngine & Manager 4.1.2. Things appear to be working well. However, in testing if I reboot the machine at all when it comes back up the Wowza Services are not running. This is a Centos 7 System. Fresh install on a staging machine. If I manually start/restart the service with systemctl everything works as expected. Just not sure why it is not starting up like it should. Not sure if anyone else is having this issue.

  2. #2
    Join Date
    Sep 2011


    This is usually caused when the server starts and Wowza tries to start before the NIC has started. As a result Wowza fails authentication as you don't have internet access and this means that Wowza doesn't start.
    When starting Wowza manually the server does have internet access and so the authentication is passed and Wowza starts as expected.

    To resolve this problem you can configure Wowza to have a delayed start so that your NIC has a chance to start first to avoid the failing authentication with the licensing server. You will need to edit the /lib/systemd/system/<wowza service> then the [unit] section contains a "After=" option which you can then put or something similar from your system so that Wowza will wait to be started when the network is already active.


  3. #3


    I thought it could be something to this effect similar to CIFS needing delayed. However, I have no systemd-wowza anything in my /lib/systemd folder.

  4. #4


    Not sure what is going on but nothing I have tried is working. I do not see a systemd.WowzaStreamingEngine service listed anywhere. I do have a S80WowzaStreamingEngine in my /etc/rc.d/rc3.d however. It is set to start late but I am still not getting the service to start after a reboot. I can work around this but I need them to start after a restart for our less versed users who are not as familiar with terminals etc.

  5. #5
    Join Date
    Dec 2014


    Has anyone found a resolution for this issue? I'm currently experiencing the same issue under the same circumstances. Thanks!

  6. #6
    Join Date
    May 2015


    I exactly have the same problem.
    I have centos 7 installed and WowzaStreamingEngine. At the end of the installation, I answered "yes" to add the service at the startup.
    If I do chkconfig --list, I see the service listed in the runlevel 2-3-4-5
    However the service doesn't start when I reboot.

    Any help?

Similar Threads

  1. Replies: 2
    Last Post: 02-14-2015, 12:01 AM
  2. Replies: 3
    Last Post: 08-13-2014, 10:21 AM
  3. WowzaStreamingEngine IPv6
    By jhlee1th in forum On-Demand Streaming
    Replies: 1
    Last Post: 07-10-2014, 06:26 AM
  4. ModuleSecureURLParams on WowzaStreamingEngine ?
    By Florent.T in forum Live Streaming and Encoders
    Replies: 7
    Last Post: 04-22-2014, 11:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts