Results 1 to 6 of 6

Thread: ModuleOnConnectAuthenticate2 doesnt work with the current version of Wowza ??

  1. #1

    Default ModuleOnConnectAuthenticate2 doesnt work with the current version of Wowza ??

    I tried to implement authentication use the following post :

    http://www.wowza.com/forums/content....age=2#comments

    The problem is that even when I do not enter the username and password in the URL , my client STILL CAN CONNECT to the application.

    I have already restarted the application several times but the problems still occured. I checked on the module list and I saw this line : moduleOnConnectAuthenticate Authenticates RTMP in Flash. com.wowza.wms.plugin.collection.module.ModuleOnConnectAuthenticate2

    Does this module still work with the newest version of Wowza ( I am using the Developer License) ?? My client still can connect to the application even when I do not enter the username and password or put wrong username and password in it.

    Please tell me how to resolve this. Thanks.

  2. #2

    Default

    Hello there and welcome to the Wowza support forum.

    Please work through this guide, as it sounds like you have not properly configured the module:
    How to do file-based authentication with RTMP client and credentials in querystring of the RTMP URL (ModuleOnConnectAuthenticate2) Edit

    Please let us know if you are still having trouble after you followed the guide correctly.

    Kind regards,

    Salvadore

  3. #3

    Default

    The link I gave is the same as the link you gave. I restarted and also checked on the modules list (as I mentioned above). I also open Incoming Security > RTMP Publishing > Require Password Authentication .

    In the Modules list of my application, I also saw moduleOnConnectAuthenticate Authenticates RTMP in Flash. com.wowza.wms.plugin.collection.module.ModuleOnConnectAuthenticate2

    I also restarted the application. I followed every step of the guide. Only for the usernamePasswordProviderClass, I do not set because I don't use it.

    What makes you think I did not follow the guide correctly ??

    Please tell me how to solve this. Thank you.

  4. #4
    Join Date
    Jan 2015
    Posts
    357

    Default

    Hi,

    This module is still compatible with the latest version of Wowza. Please do send a support request to support@wowza.com from an email account with valid entitlement so that we can further investigate the issue on your configuration.

    Kindly include:
    1. A zip file of the [install-dir]/conf
    2. A zip file of the [install-dir]/logs
    3. A link to this thread for reference

    Michelle

  5. #5

    Default

    Sorry for the late reply - it is because you replied 8 days after my last reply so I did not know.

    I sent an email with the information you require to support@wowza.com . Thank you. I am looking forward to your reply.


    sorry the email display was a bit mess up:
    Instead of

    In the Modules section, I have this line

    moduleOnConnectAuthenticate


    In the Properties, Custom Properties I have this line :

    Authenticates RTMP in Flash. com.wowza.wms.plugin.collection.module.ModuleOnConnectAuthenticate2


    /Root/Application rtmpAuthenticateFile String ${com.wowza.wms.context.VHostConfigHome}/conf/connect.password


    It should be

    In the Modules section, I have this line

    moduleOnConnectAuthenticate Authenticates RTMP in Flash. com.wowza.wms.plugin.collection.module.ModuleOnConnectAuthenticate2


    In the Properties, Custom Properties I have this line :

    /Root/Application rtmpAuthenticateFile String ${com.wowza.wms.context.VHostConfigHome}/conf/connect.password


    Last edited by todafuture; 06-04-2015 at 02:00 AM.

  6. #6
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    This will now be handled in the created ticket (130336).

    Regards,
    Jason

Similar Threads

  1. Closed Captions doesnt work for android with jw player
    By Aiman Kazi in forum Closed Captioning
    Replies: 9
    Last Post: 05-22-2015, 12:10 AM
  2. Wowza Intergrate with Kaltura current version
    By babinlonston in forum Tutorials
    Replies: 2
    Last Post: 07-22-2014, 08:13 AM
  3. hls doesnt work
    By cochin007 in forum General Forum
    Replies: 1
    Last Post: 07-12-2012, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •