Results 1 to 10 of 10

Thread: GoCoder not connecting on Android device - only in local Wlan and not via 3G

  1. #1
    Join Date
    Apr 2015
    Posts
    6

    Default GoCoder not connecting on Android device - only in local Wlan and not via 3G

    Hello! I installed Gocoder on my Samsung Galaxy Mini 4s. GoCoder only connects to the Wowza server engine when it is in the same WLAN network, but not over 3G. Any advice for this situation? I already found similar problems in the forum, but also it obviously works on some devices...
    Thank you!
    Andreas
    Last edited by azitek; 04-18-2015 at 01:57 PM.

  2. #2
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi
    I would first confirm that the Wowza Streaming Engine server is accessible on the internet from the device over 3G/4G by hitting your external IP address based URL
    from a browser.

    example:
    http://[WowzaExternalIPaddress]:1935
    Check to see if publishing while connected to a WLAN external to your server, works as well.

    Daren
    Last edited by daren_j; 04-19-2015 at 09:36 PM.

  3. #3
    Join Date
    Apr 2015
    Posts
    6

    Default

    Hello! I checked it - I only can see a message on the streaming engine in the browser on the same computer, but not in the same and out of the network? Maybe because here is a firewall active? I am at a university...http://141.244.110.62.1935 is my server

    Thank you!
    Andreas
    Last edited by azitek; 04-21-2015 at 04:13 AM.

  4. #4
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi,
    It is likely that the problem is the firewall. With online port checkers I see that port 1935 is being blocked, or is closed (not open to the public).
    Since 3G / 4G places you on the public internet it requires you to go back through your firewall. That port would need opening for this too work.


    Best regards
    Daren

  5. #5
    Join Date
    Apr 2015
    Posts
    6

    Default

    Dear Daren!
    I also have an instance on my laptop at home. I use WLAN. I have 10.0.0.4:1935 as host, and my application is CSI with CSI as publisher and 1234 as login…again, my handy via 3G cannot find the server engine…is the problem, that I run my laptop via WLAN at home? It works when I am in the same WLAN network…maybe I understand something wrong in setting up a fixed server…I really want to get it work…my idea would be to have the server run on my computer and go in the internet via a mobile WLAN station (150 Mbits download and 50 Mbits upload) – via 3G or 4G. Will this work? And use multiple handys with GoCoder distributed comin in from the internet.?xy

  6. #6
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi,
    Yes this is possible, but you have to ensure that your Wowza Streaming Engine server is accessible from the internet side of your firewall.
    You will need to forward a port (1935 or other) on your firewall to port 1935 on your Wowza server.
    This is necessary because when your device is on 3G it is accessing the internet directly and is not on your WLAN at all.
    If you're not sure how to do this on your own firawall or router, look at the port forward guides here.

    Daren

  7. #7
    Join Date
    Apr 2015
    Posts
    6

    Default

    Dear Daren! Thank you very much! Now I have found a solution...although I still fo not know, how it exactly works...I have bought a Webgate3 LTE modem and also a fixed IP address. Now I can send the handy stream to this fixed IP address (set at GoCoder as host) - and in the router I forward this stream to the IP and port in WOWZA (set in the firewall settings) - and this works! I am very happy now to have found this solution...do you know how much bandwith I might need to get 11 handystreams via GoCoder in? Thank you! Best!
    Andreas

  8. #8
    Join Date
    Apr 2015
    Posts
    6

    Default

    Dear Daren! I now wanted to test the same setup on the final desktop, where it will be applied..

    I have now installed a router with a fixed IP – 77.119.245.59 – to which I send the GoCoder stream from my Android handy. On the LTE Webgate3 modem, I have forwarded the stream to IP 192.168.0.105 – which is the IP of the wowza streaming engine here on the desktop.

    As described above I had a similar setup on my laptop, and it worked (sometimes).

    But on this desktop computer I cannot get it work.

    The application is: “stream” the incoming publisher is “Zitek” with “1234” as password.

    It says often connecting but nothing happens…

    As I said, the same setup worked sometimes on my laptop (but also with most of the time searching for a connection) – but here I cannot get it work.

    Any idea? Thank you!
    Andreas

  9. #9
    Join Date
    Apr 2015
    Posts
    6

    Default

    Dear Daren! I could solve the problem, it was a combination of the fixed IP not working properly, and then the local firewall, that blocked the signal. Now the firewall is completely off - how does the firewall for wozwa streaming look like? Any idea? So I could only open teh firewall for this application...Thank you!
    Best!
    Andreas

  10. #10
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi,
    Glad you have this working.
    The ports usually required are given here. Also see the
    *note given a little further down that page. You need to open at least port 1935 as that is the streaming port.

    Daren

Similar Threads

  1. gocoder not connecting to local wowza on mac os-x
    By jhoward88 in forum GoCoder Encoding App
    Replies: 1
    Last Post: 11-20-2014, 01:44 AM
  2. Replies: 1
    Last Post: 02-21-2014, 07:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •