Results 1 to 5 of 5

Thread: Publishing stream problem

  1. #1
    Join Date
    May 2015
    Posts
    3

    Exclamation Publishing stream problem

    Hello,

    I'm new using wowza streaming engine but so far I've managed to stream my live video feed via LAN - I was able to stream it to wowza streaming live engine with FMLE and then play it back in another computer with VLC.
    What I need to do now and I don't know how is to play my live stream video in another computer in another network. So basically I just want to make my livestream public and let other people watch it!
    I've tried copying the URL that I used in the VLC : rtsp://172.24.151.225:1935/live/myStream and play it with the wowza players but it doesn't play my video and I get an error. I even tried with the mobile links and nothing.

    I believe this has to be something really simple but I've been looking around everywhere and I can't find anything
    Can anyone please help me with this?
    Thanks in advance!

  2. #2

    Default

    Hi,

    It sounds like you may need to port forward TCP port 1935 (in your router) to the computer running Wowza. Or on your network you need to map port 1935 to the server running Wowza.

    A simple test would be to connect to the server remotely(outside of your network)
    If you enter [wowza-ip]:1935 in a browser remotely, it should display Wowza version and build numbers. If not port forwarding is in order.

    And use a public IP in the player instead of a private IP . If you don't know what it is, you can see it here: http://www.dnsstuff.com

    This is a helpful resource:
    http://portforward.com/

    Kind regards,

    Salvadore

  3. #3
    Join Date
    May 2015
    Posts
    3

    Default

    Thanks for your answer Salvadore.
    I don't understand why and how should I get a public IP address? shouldn't I copy the addresses/IP given by wowza? Shouldn't wowza have some sort of easier way to publish the stream other than allowing viewers manually? (which the way I see it is kinda what you're saying)
    the wowza-ip you mentioned above, where can I find this? I thought this was the 172.24.151.225 given by wowza. Should I just change the IP here: rtsp://172.24.151.225:1935/live/myStream to my public IP? Will that work?

    I bet this has some easy resolution but I really don't get it!
    Thanks in advance!
    Last edited by dianadfonseca; 05-04-2015 at 04:40 AM.

  4. #4

    Default

    The configuration you have is a private network. In order to be able to view the streams from outside of the private network, either the server must have a public ip address or you will need to forward the streaming ports from your public facing router (the router that connects your network to the internet) to the server running Wowza Streaming Engine.

    How you do this depends on the router and you will have to refer to it's documentation.

    If the server already has a public ip address then it could just be that Wowza Streaming Engine is displaying the ip address of the first network adaptor that it detects which in this case is the private network adaptor.

    If you are using a default installation (haven't specifically set ip addresses) then you should just be able to change the ip address in the encoders and players to the public ip address of your server.

    Salvadore

  5. #5
    Join Date
    May 2015
    Posts
    3

    Default

    Thanks for the answer again!
    I did the port forwarding now for the 1935 port and when I try to connect it remotely it doesn't allow me but through LAN it works.
    Also, I do not have a public ip address of my server (or at least if wowza has it I don't know where). I thought wowza worked as a server (public one). Am I wrong? I'm really confused now
    Sorry for all the questions but I'm a bit stuck here

    Thanks again

Similar Threads

  1. a problem about publishing a live stream with SDP file
    By z297470279z in forum Live Streaming and Encoder Discussion
    Replies: 0
    Last Post: 10-09-2012, 11:19 PM
  2. RTMP Push Publishing AddOn package problem
    By novazion in forum Server-side Modules and Code Samples Discussion
    Replies: 3
    Last Post: 04-10-2012, 06:40 AM
  3. Problem to publishing Live on Android device
    By I3Live in forum Live Streaming and Encoder Discussion
    Replies: 10
    Last Post: 03-29-2012, 12:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •