Results 1 to 3 of 3

Thread: Wowza Manager error

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    May 2015
    Posts
    2

    Default Wowza Manager error

    Hi,
    I have an problem acessing the manager interface , the manger started with no errors in log but when I access http://localhost:8088/enginemanager/ I get eh below exception :

    ava.lang.SecurityException: class "org.apache.jasper.runtime.AnnotationHelper"'s signer information does not match signer information of other classes in the same package
    at java.lang.ClassLoader.checkCerts(Unknown Source)
    at java.lang.ClassLoader.preDefineClass(Unknown Source)
    at java.lang.ClassLoader.defineClass(Unknown Source)
    at java.security.SecureClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.defineClass(Unknown Source)
    at java.net.URLClassLoader.access$100(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at net.winstone.loader.FilteringClassLoader.loadClass(FilteringClassLoader.java:93)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    .
    .
    .
    .


    Any Idea what could be the problem?

  2. #2
    Join Date
    Jan 2015
    Posts
    323

    Default

    Hi alaa,

    Have you changed your [install-dir]/conf/Server.xml configuration by any chance? If so, please post your Server.xml file (removing/obfuscating any personal information).

    Michelle

  3. #3
    Join Date
    May 2015
    Posts
    2

    Default

    Server.xml is the default one , no changes , here it is:

    <?xml version="1.0" encoding="UTF-8"?>
    <Root version="2">
    <Server>
    <Name>Wowza Streaming Engine</Name>
    <Description>Wowza Streaming Engine is robust, customizable, and scalable server software that powers reliable streaming of high-quality video and audio to any device, anywhere.</Description>
    <RESTInterface>
    <Enable>true</Enable>
    <IPAddress>*</IPAddress>
    <Port>8087</Port>
    <!-- none, basic, digest-->
    <AuthenticationMethod>digest</AuthenticationMethod>
    <DiagnosticURLEnable>true</DiagnosticURLEnable>
    <SSLConfig>
    <Enable>false</Enable>
    <KeyStorePath></KeyStorePath>
    <KeyStorePassword></KeyStorePassword>
    <KeyStoreType>JKS</KeyStoreType>
    <SSLProtocol>TLS</SSLProtocol>
    <Algorithm>SunX509</Algorithm>
    <CipherSuites></CipherSuites>
    <Protocols></Protocols>
    </SSLConfig>
    <IPWhiteList>127.0.0.1</IPWhiteList>
    <IPBlackList></IPBlackList>
    <EnableXMLFile>false</EnableXMLFile>
    <DocumentationServerEnable>false</DocumentationServerEnable>
    <DocumentationServerPort>8089</DocumentationServerPort>
    <!-- none, basic, digest-->
    <DocumentationServerAuthenticationMethod>digest</DocumentationServerAuthenticationMethod>
    <Properties>
    </Properties>
    </RESTInterface>
    <CommandInterface>
    <HostPort>
    <ProcessorCount>${com.wowza.wms.TuningAuto}</ProcessorCount>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <Stats>
    <Enable>true</Enable>
    </Stats>
    <!-- JMXUrl: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>false</Enable>
    <IpAddress>localhost</IpAddress> <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>localhost</RMIServerHostName> <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <Streams>
    <DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    <ServerListeners>
    <ServerListener>
    <BaseClass>com.wowza.wms.mediacache.impl.MediaCacheServerListener</BaseClass>
    </ServerListener>
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerListener</BaseClass>
    </ServerListener>
    -->
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerSender</BaseClass>
    </ServerListener>
    -->
    </ServerListeners>
    <VHostListeners>
    <!--
    <VHostListener>
    <BaseClass></BaseClass>
    </VHostListener>
    -->
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>

    <Manager>
    <!-- Properties defined are used by the Manager -->
    <Properties>
    </Properties>
    </Manager>

    <!-- Properties defined here will be added to the IServer.getProperties() collection -->
    <Properties>
    </Properties>
    </Server>
    </Root>

Similar Threads

  1. Engine Manager Forbidden (403) error
    By kalmatv in forum General Forum
    Replies: 4
    Last Post: 03-06-2014, 09:20 AM
  2. Replies: 2
    Last Post: 10-07-2013, 08:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •