Results 1 to 5 of 5

Thread: background noise from Flash client (this worked with Flash Media Server 7 years ago)

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default background noise from Flash client (this worked with Flash Media Server 7 years ago)

    I uses the same Flash client that works without background noise on Flash Media Server 7 years ago. It was fine.

    This time I use Wowza Media Server. Suddenly this noise audio problem occurs. BACKGROUND ANNOYING NOISE.

    I have tried and looked for places on Internet but no place has a solution.

    I added Echo Cancellation. Echo Cancellation also looks like not a solution for this background noise because I added Echo cancellation and the noise was still there.
    mic = Microphone.getEnhancedMicrophone();
    var options : MicrophoneEnhancedOptions = new MicrophoneEnhancedOptions();
    options.mode = MicrophoneEnhancedMode.FULL_DUPLEX;
    options.autoGain = false;
    options.echoPath = 128;
    options.nonLinearProcessing = true;
    mic['enhancedOptions'] = options;

    mic.gain = 40;
    mic.rate = 16;
    mic.setSilenceLevel(5, 1000);

    Anyone knows how to resolve this? I dont know if this is Wowza problem or code problem because this code worked without noise on Flash Media Server 7 years ago. (without even using Echo Cancellation above)

  2. #2


    There is no Wowza solution for this problem.
    Maybe there is something in the Flash Microphone MicrophoneEnhancedOptions, but I'm not sure.



  3. #3


    I showed you the code of MicrophoneEnhancedOptions in the first post. It doesn't solve this strange annoying noise problem. The code without using MicrophoneEnhancedOptions worked on Flash Media Server 7 years ago without noise problem. Too long ago so I dont remember if at that time, I used an external mic or not--> that probably helped no noise. But now I don't know how to solve this noise problem when using a mic that is included in the laptop.

  4. #4
    Join Date
    Sep 2011


    I recommend using a different capture device (microphone/camera) this could be an external or even a different machine altogether. If you're not getting the same result when using a completely different capture device, laptop or desktop PC then would suggest an issue is caused by either the capture device itself or the machine using it. As Salvadore stated, this is not something that can be fixed within Wowza, as Wowza can only provide what it receives.


  5. #5


    I tried another laptop, but the same problem occurred. I think the problem should not be the laptop because using Skype is fine using these mic and webcam. The code also worked fine 7 years ago using Flash Media Server.

Similar Threads

  1. Live Audio Streaming: Background Noise/Disturbance
    By Jaskaran81 in forum General Forum
    Replies: 4
    Last Post: 11-19-2012, 11:19 AM
  2. background httprequests
    By atypical in forum Server-side Modules and Code Samples Discussion
    Replies: 7
    Last Post: 05-30-2012, 06:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts