Results 1 to 2 of 2

Thread: Problem RTMP Stream with no audio

  1. #1
    Join Date
    May 2015
    Posts
    1

    Default Problem RTMP Stream with no audio

    Hi,

    I have setup my Wowza to take in live stream from RTSP web camera and I can view the output RTMP stream on VLC player.
    But the same RTMP stream on my Wowza Test Player show only black screen when playing (Status: Started playing camera1.stream).
    Is it because the source Audio is empty / non-supported?
    Both cameras below are showing black screen on RTMP streaming.
    Please advise.

    I'm using Wowza Streaming Engine: 4.1.2

    Camera 1 log:
    INFO server comment - LiveStreamPacketizerCupertino.handlePacket[live/_definst_/camera1.stream]: Video codec:H264 isCompatible:true
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[live/_definst_/camera1.stream]: Add chunk: id:1 mode:TS[H264,NOAUDIO] a/v/k:0/64/2 duration:10103

    Camera 2 log:
    INFO server comment - LiveStreamPacketizerSanJose.handlePacket[live/_definst_/camera6.stream]: Video codec: H264
    INFO server comment - LiveStreamPacketizerSanJose.handlePacket[live/_definst_/camera6.stream]: Audio codec: G711_ALAW
    INFO server comment - LiveStreamPacketizerCupertino.endChunkTS[live/_definst_/camera6.stream]: Add chunk: id:1 mode:TS[H264,G711_ALAW] a/v/k:0/225/9 duration:9000

  2. #2

    Default

    Hi,

    Please take a look at the How to specify per-stream settings in .stream files forum article which describes how to specify per-stream settings in .stream files to override those in the application configuration for the stream.

    Please enable the rtspFilterUnknownTracks, rtpIgnoreProfileLevelId and rtpIgnoreSPropParameterSets. In some cases, for some IP cameras, these settings can help with the playback of RTMP streams. Let me know if that works in your case.

    Also, G711 audio is only supported for Transcoding through the Wowza Transcoder.

    Regards,

    Salvadore

Similar Threads

  1. Problem with interleaved live stream with audio on RTMP player
    By ozgurdeniz in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 01-17-2014, 05:59 AM
  2. audio problem of rtmp with h.264 and mp3
    By shadowlin in forum Media Players and Devices Discussion
    Replies: 8
    Last Post: 07-09-2012, 10:13 AM
  3. audio problem with flash player 11.2 occurs only with Stream class stream
    By jachai in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 04-04-2012, 08:11 AM
  4. relay (repeater) rtmp video/audio to rtmp audio only output (strip video)
    By dptekco in forum Live Streaming and Encoder Discussion
    Replies: 4
    Last Post: 03-22-2012, 07:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •