Results 1 to 5 of 5

Thread: RTSP restreaming to YouTube

  1. #1
    Join Date
    May 2015

    Default RTSP restreaming to YouTube

    I'm having the exact problem as this person:

    I have a trial version and want to restream a RTSP to YouTube, After setting it in stream file, I can view the stream from connecting to Wowza over flash (RTMP). I've edited the PubPublishMap files with the appropriate information and restart the server but nothing?

    There are no error messages or any messages in both log files.

    It would help if the solution was public rather than inside a ticket. I am thinking of purchasing the monthly license to run on my server but still unsure.


  2. #2
    Join Date
    Dec 2014



    The forum post you referred to above was resolved by setting up the push publish module. Have you configured the Push Publish Module?



  3. #3
    Join Date
    May 2015


    I'm going to enable debugging and move the PushPublishMap file into the applications folder to see if that helps. When you say setting up the publish module do you mean editing the file to include the line:

    Is there anything else / more to do after that, because I've done this already? I can't find any GUI configuration inside the web admin panel to configure the module.


    Also to add: When I click test player , I see "myStream" already added and try to click play in all the players and it does not work, however when I go into "Incoming Streams" > Click the RTSP stream > Test Player, I can view the stream fine.

    So instead of "myStream" inside PushPublishMap I've changed it to the same stream name that appears inside Test Player. This does not work either...
    Last edited by mortigamer; 05-24-2015 at 12:54 AM.

  4. #4
    Join Date
    May 2015


    Working, I did not set the modules up properly. Anyone reading this, ensure you have changed the admin user to access dev options.

    Now I have a different error from YouTube telling me this.

    Please use a keyframe frequency of 2 seconds or less. Keyframes are not being sent often enough, this will cause buffering. Current keyframe frequency: 14.8 seconds. GOP sizes can be wrong if you have ingestion errors.

    Is there anyway of doing this without transcoding, I dislike having the watermark on their.

  5. #5
    Join Date
    May 2015


    I have a simmilar issue: I can't publish to Youtube.

    I setup correctly Youtube account to get the app name, stream, etc.

    I have Wowza Stream Engine 4.1.1. Have variuos applications. In a particular application, that I want to send to Youtube, I have two streams:

    live_1 (1080p) (I want to send this to Youtube: H264 video, AAC audio)
    live_2 (480p)

    They come from Flash Media Encoder (this work fine in the test players on Wowza and on VLC) Ej:


    I configured the Push Publishing Module ok in the app whith a user whit these privileges.

    Then, I edited the /conf/PushPublishMap.txt in Wowza server adding the code:

    live_1={profile:"rtmp", streamName:"xxxxxxxx.xxxx-xxxx-xxxx-83uc", host:"", application:"live2"}
    live_1={profile:"rtmp", streamName:"xxxxxxxx.xxxx-xxxx-xxxx-83uc", host:"", application:"live2?backup=1"}
    Then restart Wowza but nothing happens in Youtube (says streaming is not present or incomming).

    Its ok the name of stream "live_1={..." on the syntax?
    What Iam doing wrong?


    PS: Sorry for my english and/or if Iam broken any rule of the forum. Iam new on this.
    Last edited by jpossetti; 05-26-2015 at 04:10 PM.

Similar Threads

  1. Pull stream from RTSP/RTP device, pushed out to YouTube
    By Blaeven in forum Live Streaming and Encoders
    Replies: 7
    Last Post: 06-18-2015, 11:59 PM
  2. RTSP streaming over Youtube Live from WOWZA not working
    By rahimcs027 in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 04-07-2015, 11:28 AM
  3. RTSP streaming over Youtube Live from WOWZA not working
    By rahimcs027 in forum Wowza Streaming Engine functionality
    Replies: 3
    Last Post: 04-07-2015, 11:28 AM
  4. Module PushPublish. Problems publishing to Youtube from Wowza with rtsp as source.
    By juanjo.torroglosa.droider in forum Other Extensions
    Replies: 3
    Last Post: 11-04-2014, 09:24 AM
  5. Shoutcast restreaming issue - restreaming other stream
    By del-mt in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 11-29-2012, 12:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts