Results 1 to 10 of 12

Thread: Apple media stream validator tool

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Aug 2011
    Posts
    116

    Default Apple media stream validator tool

    Hi

    I am using wowza 4.1.2 and stream HLS
    I defined CupertinoMaxChunkCount of 15 and PlaylistCunkCount of 6

    In some devices I get disconnected after a couple of minutes

    I used Apple media stream validator tool to validate the stream
    And I am getting Errors and warnings

    Why Am I getting those errors (also happen when i play sample.mp4)?

    Also can you explain to me what the last warning means and how can i tackle it?


    Playlist Syntax:

    Warning: (-31000:0) Old codec format (RFC 4281) subelements found. Use format specified by RFC 6381
    --> Detail: Subelements: 100.30
    --> Compare URL: chunklist_w194544374.m3u8

    Alternate playlist(s):

    --------------------------------------------------------------------------------
    chunklist_w194544374.m3u8
    --------------------------------------------------------------------------------

    Playlist Syntax: OK

    Processed 18 out of 18 segments:

    media_w194544374_111.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_112.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_113.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_114.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_115.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_116.ts:

    WARNING: Media segment bandwidth exceeded target playlist bandwidth
    --> Bandwidth exceeded by 27 % ( 1.96 Mbits/sec vs 1.54 Mbits/sec, limit is 10 %)


    media_w194544374_117.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256


    media_w194544374_118.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_119.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_121.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256


    media_w194544374_123.ts:

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 256

    ERROR: (-12976) Received discontinuity error
    --> Track ID: 257


    media_w194544374_124.ts:

    WARNING: Media segment bandwidth exceeded target playlist bandwidth
    --> Bandwidth exceeded by 21 % ( 1.87 Mbits/sec vs 1.54 Mbits/sec, limit is 10 %)

  2. #2

    Default

    Hi,

    mediasteamvalidator shouldn't be showing any errors when run against for example sample.mp4. This is if using the default "vod" app in Wowza, e.g.

    mediastreamvalidator -V http://[wowza-server]:1935/vod/mp4:sample.mp4/playlist.m3u8
    I've just done a test myself using mediastreamvalidator version 1.1 and Wowza 4.1, and sample.mp4 passes all tests.

    So it could be your cupertino properties in your Wowza application. Please try creating a new "vod" application and doing the test again using our sample.mp4 file.


    Paul

  3. #3
    Join Date
    Aug 2011
    Posts
    116

    Default

    The vod workes.

    Also the recorded shows from the live stream.
    The only issue at the moment is that the live tsream dissconects after few minutes.

    very strange
    I have tried to "play" with cupertinoPlaylistChunkCount decreasing or increasing but with little luck
    anything else maybe i need to check?

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    To take a closer look, please create a ticket by emailing support@wowza.com.
    When creating a ticket, please include a ZIP file containing the following directories:
    [Wowza-Install]/conf/
    [Wowza-Install]/logs/
    [Wowza-Install]/transcoder/

    Please make sure you provide logs which show Wowza server starting.

    If you are not sure how to get this information please see the following tutorial.
    How to create a compressed zip file in Windows, OS X, and Linux

    As you have a live stream please outline the type of encoder in use along with the encoding settings for the stream.
    Please include a link to this thread for reference.

    Regards,
    Jason

  5. #5
    Join Date
    Aug 2011
    Posts
    116

    Default

    Hi jason

    The issue is resolved.
    an encoder issue

    /thx

  6. #6
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    Thanks for the update.
    I'm glad we managed to find the cause of the problem.

    Regards,
    Jason

Similar Threads

  1. Warnings when using media stream validator on HLS VOD content
    By SimonShapcott in forum General Forum
    Replies: 7
    Last Post: 12-04-2012, 06:58 AM
  2. Apple Media Validation Tool / Unable to read video timestamps
    By Inspiring in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 09-11-2012, 07:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •