Results 1 to 5 of 5

Thread: loadHTTPProvider error

  1. #1

    Default loadHTTPProvider error

    Hello , I am in process of developing a Wowza service for broadcasting on am Amazon + wowza+ cloudfront setup with a bit of extra logic .
    The application runs smooth when tested on local machine via Eclipse IDE . However the same settings on amazon shows loadHTTPProvider error .

    I have tried changing the permission and owner to same as other for my application components inside conf and applications folders however all in vain as it doesnot show me required output . However the basic functionality of publishing and viewing a stream works fine so that proves that application is loaded but not all the components .

    Here is the error trace . Any help on suggesting what might be missing here are most welcomed .

  2. #2
    Join Date
    May 2013



    You might be sure that you've included your custom HTTP Provider .jar file on your production platform within the [wowza-dir]/lib folder (along with any dependent .jar files). If you continue to have problems, please send a zip file of your conf/ and lib/ directories to so we can review it further.



  3. #3


    Hello , I managed to solve time back . I was due to absece of a JSON jar which was resulting in pseudo builds and hence the jar in lib folder wasnot updated with my latest builds . Anyhow , my latest problem is that the stream successfully plays on test players with amazon url and 1935 port but yields a 2048 error on being played through cloudfront .

    please share if a new thread need to be opened for this ssue or it can be solved here itself .

  4. #4
    Join Date
    Jun 2012



    When you created the Cloudfront distribution, did yous specify that it needs to use port 1935 when connecting to the Origin server? When creating the Cloudfront distribution you also need to specify the HTTP port to be used when connecting to the Origin server. By default this is set to 80, so if your Wowza server is not using port 80 for streaming, the Cloudfront distribution will not be able to access the streams provided by Wowza.


  5. #5


    Thank you for the solution I figured out the port mismatch and have been able to successfully stream from Wowza to cloudfront and view it on players . However I am facing a issue with signedCookie and have made another thread for it here .
    Request you to please help me resolve it .

Similar Threads

  1. Replies: 1
    Last Post: 07-12-2012, 11:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts