Results 1 to 2 of 2

Thread: Looking for a jar that contains WMSReadWriteLock

  1. #1

    Default Looking for a jar that contains WMSReadWriteLock

    I am trying to locate the Jar in the lib folder that contains the following reference:

    I do not seem to see it listed in there by itself, I am guess it is rolled into another jar?

    I am trying to setup a unit test against IApplicationInstance using mockito test framework. It is hung up on resolving this reference. Anyone have any idea where this is located?

    I tried adding a maven reference to it for all available versions 1-3.1 and still no luck getting past the error. The full error is:

    java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/locks/WMSReadWriteLock
    at Method)
    at java.lang.ClassLoader.loadClass(
    at sun.misc.Launcher$AppClassLoader.loadClass(
    at java.lang.ClassLoader.loadClass(
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(
    at java.lang.Class.getDeclaredMethods(
    at org.mockito.cglib.core.ReflectUtils.addAllMethods(
    at org.mockito.cglib.proxy.Enhancer.getMethods(
    at org.mockito.cglib.proxy.Enhancer.generateClass(
    at org.mockito.cglib.core.DefaultGeneratorStrategy.generate(
    at org.mockito.cglib.core.AbstractClassGenerator.create(
    at org.mockito.cglib.proxy.Enhancer.createHelper(
    at org.mockito.cglib.proxy.Enhancer.createClass(
    at org.mockito.internal.creation.jmock.ClassImposterizer.createProxyClass(
    at org.mockito.internal.creation.jmock.ClassImposterizer.imposterise(
    at org.mockito.internal.creation.jmock.ClassImposterizer.imposterise(
    at org.mockito.internal.creation.CglibMockMaker.createMock(
    at org.mockito.internal.util.MockUtil.createMock(
    at org.mockito.internal.MockitoCore.mock(
    at org.mockito.Mockito.mock(
    at org.mockito.Mockito.mock(

    the test case looks like this:

    IApplicationInstance appInstance = mock(IApplicationInstance.class);

    Anyone encountered this issues trying to mock this class? Any help would be great.

  2. #2


    Hello there.

    Do you have this import statement:
    If so you and it still doesn't work, might consider opening a ticket with support. To do so follow this guide and send requested information to
    How to create a compressed zip file in Windows, OS X, and Linux



Similar Threads

  1. WowzaServerAddOnCollection contains no jar files
    By bison121261 in forum Server-side Modules and Code Samples Discussion
    Replies: 2
    Last Post: 03-12-2013, 02:09 AM
  2. Replies: 1
    Last Post: 09-05-2012, 06:25 PM
  3. smil file The F4M document contains errors URL missing from Media tag
    By hockey_dave in forum Live Streaming and Encoder Discussion
    Replies: 7
    Last Post: 04-25-2012, 10:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts