Results 1 to 2 of 2

Thread: NullPointerException in PushPublishRTMP

  1. #1
    Join Date
    Jun 2015
    Posts
    1

    Default NullPointerException in PushPublishRTMP

    Hi,

    I am using wowza in a live streaming use case in which incoming RTP over RTSP data is transcoded to RTMP. The RTMP stream is being pushed to an akamai entry point server. I am able to do this succefully. However i see exceptions being generated from within Wowza PushPublishRTMP module. The following is the log generated:

    2015-06-16 03:11:26 PDT comment server ERROR 500 - service : java.lang.NullPointerException|at com.wowza.wms.pushpublish.protocol.rtmp.PushPublishRTMP$PublishHandler.sendPackets(PushPublishRTMP.j ava:808)|at com.wowza.wms.pushpublish.protocol.rtmp.PushPublishRTMP$PublishHandler.play(PushPublishRTMP.java:115 7)|at com.wowza.wms.netconnection.NetConnectionAdapter.service(NetConnectionAdapter.java:173)|at com.wowza.wms.netconnection.NetConnectionSessionHandler.a(NetConnectionSessionHandler.java:202)|at com.wowza.wms.netconnection.NetConnectionSessionHandler.b(NetConnectionSessionHandler.java:96)| - - - 29009.599 - - - - - - - - - - - - - - - - - - - - - - - - -
    2015-06-16 03:11:26 PDT comment server ERROR 500 - service : java.lang.NullPointerException|at com.wowza.wms.pushpublish.protocol.rtmp.PushPublishRTMP$PublishHandler.sendPackets(PushPublishRTMP.j ava:808)|at com.wowza.wms.pushpublish.protocol.rtmp.PushPublishRTMP$PublishHandler.play(PushPublishRTMP.java:115 7)|at com.wowza.wms.netconnection.NetConnectionAdapter.service(NetConnectionAdapter.java:173)|at com.wowza.wms.netconnection.NetConnectionSessionHandler.a(NetConnectionSessionHandler.java:202)|at com.wowza.wms.netconnection.NetConnectionSessionHandler.b(NetConnectionSessionHandler.java:96)| - - - 29009.85 - - - - - - - - - - - - - - - - - - - - - - - - -

    I am able to receive and play the stream on the akamai server without any issue. I see these logs on few occasions and i am not able to reproduce it consistently. Can this cause any problem? Is there any issue with the way we are making API calls to PushPublishRTMP? Some more information below:

    Software version: WowzaStreamingEngine - v4.1.2
    OS: Ubuntu 12.04 (64 bit)

    The wowza streaming engine software is running on amazon ec2 instance

    Rakshith

  2. #2

    Default

    Hello there.

    If the stream is working maybe don't worry about it? You can always open a ticket with support by sending an email to support@wowza.com

    Follow this guide when opening a ticket please:
    How to create a compressed zip file in Windows, OS X, and Linux

    Also, you can enable debugging of push publish (if you have not done so)
    How to debug Stream Targets (push publishing)

    Regards,

    Salvadore

Similar Threads

  1. Mixing vod and live streams with PushPublishRTMP to akamai
    By anupam in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 11-06-2014, 08:14 AM
  2. PushPublishRTMP doesn't work with IPv6
    By /usr/local/dick in forum Live Streaming and Encoders
    Replies: 5
    Last Post: 08-08-2014, 12:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •