Results 1 to 8 of 8

Thread: What am I missing? Can't enable NVENC for transcoding

  1. #1
    Join Date
    Mar 2015
    Posts
    27

    Default What am I missing? Can't enable NVENC for transcoding

    Ok, is there something apart from the sparse documentation on enabling NVENC for my transcoder/transrate?

    I have an EC2 instance, g2.2xlarge, running off the ec2.nvidia.ami with Wowza 4.2 installed and running. under Ubuntu 12.04.5.

    I have the most recent drivers installed (Driver Version: 352.21) and it is working on the server side:

    ==============NVSMI LOG==============

    Timestamp : Sat Jun 27 01:26:48 2015
    Driver Version : 352.21

    Attached GPUs : 1
    GPU 0000:00:03.0
    Product Name : GRID K520
    Product Brand : Grid

    ========================

    I have the Encoder implementation NVENC in each transcode setting in both transcode and transrate. I also have NVCUVID as the decoder implementation.

    But everytime I push a stream to the transcoder I get this in the log:
    2015-06-27 01:20:39 UTC comment server INFO 200 - JNI:TranscoderSession.isCUDAAvailable[_defaultVHost_remnorec/_definst_/Live_1_1@307544]: NVidia hardware acceleration is NOT available - - - 1308.152

    Given past things I have worked through, I know it is going to be a simple thing that I missed. I think I have all the corners of configuration handled, but I am missing something.

    Anyone go through this and have a quick idea on where to go. This is crazy. I feel like I am now just throwing spaghetti at the wall with thoughts and ideas.

    Help. :-)

    Cheers,
    Bob

  2. #2

    Default

    Hello Bob,

    Please open a ticket with support by sending your request to support@wowza.com. If you could attach the following information, it will speed up your resolution time:

    - A ZIP file containing your conf/, logs/ and transcoder/ folders. If you are not sure how to get this information please see the following tutorial. Please do make sure you provide logs which show Wowza Streaming Engine starting.

    http://www.wowza.com/forums/content....c-OS-and-Linux

    Best regards,
    Andrew

  3. #3
    Join Date
    Mar 2015
    Posts
    27

    Default

    I meant to reply to this earlier.

    We downgraded to 4.1.2 and are having no problems. I will come back when we are looking at upgrading. Right now 4.2 isn't working for us.

    Thanks,
    Bob

  4. #4
    Join Date
    Aug 2015
    Posts
    1

    Default

    Had the same issue - it seems like the update to 4.2.0.01 has resolved this for us

  5. #5

    Default

    Thanks for the info on this, and for the update.

    Regards,

    Salvadore

  6. #6
    Join Date
    Oct 2015
    Posts
    1

    Default

    thanks for inf sharing on this

  7. #7

    Default

    Quote Originally Posted by thuytien146 View Post
    thanks for inf sharing on this
    I have the same problem, but on Debian Jessie, and I'm on Wowza Version 4.4.1

  8. #8

    Default

    Hi,

    We have the following guides for configuring NVENC on various distros. Note that the guides are written for specific releases and we can't guarantee that they will still work on untested releases of the distro.

    If you have compatible hardware and OS and it is still not working then please open a support ticket.


    Paul


    Paul

Similar Threads

  1. Replies: 3
    Last Post: 03-20-2015, 09:01 AM
  2. Enable Transcoding on stream from Client Call
    By hsamayoa in forum AddOn: Transcoder
    Replies: 7
    Last Post: 06-12-2012, 12:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •