Results 1 to 5 of 5

Thread: error log confused

  1. #1

    Default error log confused

    Hi,
    In my error log file, there are many error occured such as follow:

    IdleWorkerUtil: run.work : java.lang.NullPointerException|at com.wowza.wms.stream.livepacketizer.LiveStreamPacketi
    zerBase.shutdown(LiveStreamPacketizerBase.java:272)|at com.wowza.wms.stream.MediaStreamMap.removeLiveStreamPacketizer(MediaStreamMap.java:1269)|a
    t com.wowza.wms.stream.livepacketizer.LiveStreamPacketizerBase.checkTimeout(LiveStreamPacketizerBase.java:326)|at com.wowza.wms.stream.livepacket
    izer.LiveStreamPacketizerBase.onIdle(LiveStreamPacketizerBase.java:262)|at com.wowza.wms.util.IdleWorkerUtil.run(IdleWorkerUtil.java:111)
    I do not understand what's it meaning for, can someone explain why and when it would happened?

    thanks!!!

  2. #2

    Default

    Hello there.

    It sounds like you forgot to configure a VHost-level thread pool for the load test tool?

    Ensure that you have followed step 4 in the LoadTesingTool.pdf, as that's the error usually seen when that
    configuration step is not included:

    Step 4. The Load Testing tool requires the _defaultVHost_ virtual host (VHost) to have its
    own thread pool. By default, Wowza Streaming Engine is configured to use a server-level thread pool. To configure a VHost-level thread pool, edit [install-dir]/conf/VHost.xml and make the following changes:
    - HandlerThreadPool/PoolSize: 60 x [total-core-count]
    - TransportThreadPool/PoolSize: 40 x [total-core-count]

    Regards,

    Salvadore

  3. #3

    Default

    thanks!
    but i'm not using load test tool. in my workflow, ingest the udp stream, transcode it with quicksync and then pushPublish to adobe media server.

  4. #4

    Default

    I think this may have been addressed in the latest Wowza release. Please update to Wowza 4.2.0.

    Also, make sure your Java startup settings are default.

    Regards,

    Salvadore

  5. #5

    Default

    If this does not solve the problem, please open a ticket with support.

    To do so, send a zipped copy of your /conf and /logs folders to support@wowza.com Also include a link to this thread for reference.

    Regards,

    Salvadore

Similar Threads

  1. Confused - new to video streaming
    By RussellEngland in forum General Forum
    Replies: 1
    Last Post: 09-03-2012, 07:25 AM
  2. newbie confused questions
    By Devman in forum General Forum
    Replies: 5
    Last Post: 07-07-2012, 05:56 AM
  3. New and confused
    By joefriday in forum General Forum
    Replies: 2
    Last Post: 04-11-2012, 08:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •