Results 1 to 2 of 2

Thread: RTMPS inbound?

  1. #1
    Join Date
    Jul 2015

    Default RTMPS inbound?

    Hello all,

    I'm having a spot of trouble with rtmps. Outbound works fine; a remote server can connect to the WOWZA server I've set up via rtmps and download video no problem. Uploading to the WOWZA server, however, doesn't work out.

    Specifically, I'm running WOWZA 4.2.0 (build 15089) on a CentOS 6.4 box (32 bit), and using ffmpeg from another CentOS 6.4 box across a public subnet for testing (public IPs, but does not go to the internet). When I send video to it with a command like:

    PHP Code:
    ffmpeg -i rtsp://[cam username]:[cam password]@[cam IP]:554/0 -an -vcodec copy -f flv rtmps://[stream username]:[stream password]@[streamlock random string] 
    It sends some data... but not much (and I checked under the hood on the WOWZA server I put together: It's definitely getting a file). It runs at half of a frame per second... and because I'm trying to get video off of a live camera, well, ffmpeg runs out of buffer and breaks. Output:

    PHP Code:
    ffmpeg -i rtsp://[cam username]:[cam password]@[cam IP]:554/0 -an -vcodec copy -f flv rtmps://[stream username]:[stream password]@[streamlock random string]
    ffmpeg version 2.7.2-static  Copyright (c) 2000-2015 the FFmpeg developers
    built with gcc 4.9.3 (Debian 4.9.3-1)
    configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --cc=gcc-4.9
      libavutil      54. 27.100 
    54. 27.100
      libavcodec     56. 41.100 
    56. 41.100
      libavformat    56. 36.100 
    56. 36.100
      libavdevice    56.  4.100 
    56.  4.100
      libavfilter     5. 16.101 
    /  5. 16.101
      libswscale      3.  1.101 
    /  3.  1.101
      libswresample   1.  2.100 
    /  1.  2.100
      libpostproc    53.  3.100 
    53.  3.100
    #0, rtsp, from 'rtsp://[cam username]:[cam password]@[cam IP]:554/0':
    title           h264.mp4
    #0:0: Video: h264 (Main), yuv420p(tv), 1280x720 [SAR 1:1 DAR 16:9], 20 fps, 20 tbr, 90k tbn, 40 tbc
    [rtmps 0xc596300Ignoring unsupported var reason
    [flv 0xc325d80Codec for stream 0 does not use global headers but container format requires global headers
    #0, flv, to 'rtmps://[stream username]:[stream password]@[streamlock random string]':
    title           h264.mp4
    #0:0: Video: h264 ([7][0][0][0] / 0x0007), yuv420p, 1280x720 [SAR 1:1 DAR 16:9], q=2-31, 20 fps, 20 tbr, 1k tbn, 90k tbc
    Stream mapping:
    Stream #0:0 -> #0:0 (copy)
    Press [qto stop, [?] for help
    [flv 0xc325d80Non-monotonous DTS in output stream 0:0previous0current: -250changing to 0. This may result in incorrect timestamps in the output file.
    flv 0xc325d80Non-monotonous DTS in output stream 0:0previous0current: -200changing to 0. This may result in incorrect timestamps in the output file.
    flv 0xc325d80Non-monotonous DTS in output stream 0:0previous0current: -150changing to 0. This may result in incorrect timestamps in the output file.
    flv 0xc325d80Non-monotonous DTS in output stream 0:0previous0current: -100changing to 0. This may result in incorrect timestamps in the output file.
    flv 0xc325d80Non-monotonous DTS in output stream 0:0previous0current: -50changing to 0. This may result in incorrect timestamps in the output file.
    NULL 0xc2d33a0RTPmissed 4017 packetstime=00:00:01.59 bitrate867.0kbits/s
    [NULL 0xc2d33a0RTPPT=60bad cseq f793 expected=e7e2
    [NULL 0xc2d33a0RTPmissed 4018 packets
    [NULL 0xc2d33a0RTPmissed 1296 packetstime=00:01:02.78 bitrate=  28.0kbits/s
    [NULL 0xc2d33a0RTPmissed -64245 packetsme=00:01:23.16 bitrate=  28.0kbits/s
    [NULL 0xc2d33a0RTPmissed 1313 packets
    [NULL 0xc2d33a0RTPmissed 1313 packetstime=00:01:42.99 bitrate=  25.5kbits/s
    [rtsp 0xc2d0de0CSeq 8 expected5 received.=00:02:22.80 bitrate=  20.5kbits/s
    [rtsp 0xc2d0de0CSeq 8 expected6 received.
    rtsp 0xc2d0de0CSeq 8 expected7 received.
    flv 0xc325d80Failed to update header with correct duration.ate=  22.5kbits/s
    [flv 0xc325d80Failed to update header with correct filesize.
    frame=   99 fps=0.5 q=-1.0 Lsize=     394kB time=00:02:23.30 bitrate=  22.5kbits/s
    :391kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead0.573942
    I've confirmed that both machines have negligible load (8 core processors on both machines, both machines had a load of less than 0.5 while this is going on). If I run it with rtmpe, I get the same problem. If I run the exact same command via rtmp, it works flawlessly. Trouble is, after I've got everything I want up and running, the actual content of the video is going to be potentially sensitive, and will have to go over the internet. Hence, Encryption is very much required for the intended application.

    Is anyone up to helping me sort out what's going wrong and how to fix it?

  2. #2


    Hi Robert,

    I've replied to your identical post in this thread.


Similar Threads

  1. Replies: 3
    Last Post: 06-30-2015, 10:14 AM
  2. secure (rtmps) inbound streams
    By mikebo in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 06-19-2015, 02:01 AM
  3. Inbound RTSP over SSL
    By demosm in forum General Forum
    Replies: 3
    Last Post: 04-29-2015, 11:06 AM
  4. Consultant needed for load balancing inbound traffic
    By RobPreston in forum Integrating Wowza into your workflow
    Replies: 4
    Last Post: 04-16-2014, 09:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts