Results 1 to 3 of 3

Thread: URGENT : GPU transcoding not working with 4.2.0

  1. #1
    Join Date
    Apr 2014
    Posts
    15

    Exclamation URGENT : GPU transcoding not working with 4.2.0

    Hello,

    We are in the process of upgrading the Wowza Streaming Engine installation to 4.2.0, the GPU based transcoding is not working with 4.2.0, this use to work with 4.1.2

    Here are the details :
    4.1.2:
    INFO server comment - JNI:TranscoderSession.isCUDAAvailable[_defaultVHost_:live/_definst_/anupam]: NVidia NVENC hardware acceleration is available
    INFO server comment - JNI:NVidiaCUDAUtils.logCUDAGPUInfo[_defaultVHost_:live/_definst_/anupam]: GPU[0]: name:"GRID K520" version:3.0 driver:6000 memory:4095MB processors:8 cores:1536 clockRate:797MHz NVENC:yes
    Driver information :
    +------------------------------------------------------+                       
    | NVIDIA-SMI 331.113    Driver Version: 331.113        |                       
    |-------------------------------+----------------------+----------------------+
    | GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
    | Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
    |===============================+======================+======================|
    |   0  GRID K520           Off  | 0000:00:03.0     Off |                  N/A |
    | N/A   44C    P0     0W / 125W |      9MiB /  4095MiB |      0%      Default |
    +-------------------------------+----------------------+----------------------+
                                                                                   
    +-----------------------------------------------------------------------------+
    | Compute processes:                                               GPU Memory |
    |  GPU       PID  Process name                                     Usage      |
    |=============================================================================|
    |  No running compute processes found                                         |
    +-----------------------------------------------------------------------------+
    When running the 4.2.0 version :

    2015-07-27      09:06:02        UTC     comment server  INFO    200     -       TranscoderSessionNative.loadLibrary: Load transcoder list file: /usr/local/WowzaStreamingEngine/lib-native/linux64/transcoder.list      -       -       -       1843.099        -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -
    2015-07-27      09:06:02        UTC     comment server  INFO    200     -       LiveStreamTranscoder.init[live/_definst_/anupam]: Load transcoder template: file:///usr/local/WowzaStreamingEngine/transcoder/templates/transcode.xml   -       -       -       1843.118        -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -
    2015-07-27      09:06:02        UTC     comment server  INFO    200     -       TranscoderWorkerVideoScaler.init[_defaultVHost_:live/_definst_/anupam] Multi-threaded scaling is enabled. encoderCount:5        -       -       -       1843.21 -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -
    2015-07-27      09:06:02        UTC     comment server  INFO    200     -       JNI:TranscoderSession.isCUDAAvailable[_defaultVHost_:live/_definst_/anupam]: NVidia hardware acceleration is NOT available      -       -       -       1843.214        -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -       -
    2015-07-27      09:06:02        UTC     comment server  INFO    200     -       JNI:TranscoderSession.isQuickSyncAvailable[_defaultVHost_:live/_definst_/anupam]: Intel Quick Sync hardware acceleration is NOT available.      -       -       -       1843.215
    Can you take a look?

    Thanks,
    Anupam

  2. #2

    Default

    Hi,

    This issue has been resolved in 4.2.0.01 update. Please contact support@wowza.com if you require this update.

    Roger.

  3. #3
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    This was handled in ticket 135668.
    Wowza Streaming Engine software updates can be downloaded from the My Downloads tab in you Wowza account.

    Regards,
    Jason

Similar Threads

  1. NVENC encoding in linux working on GPU but also using CPU
    By brayster99 in forum Wowza Transcoder
    Replies: 9
    Last Post: 08-07-2014, 11:12 PM
  2. Replies: 1
    Last Post: 07-28-2014, 04:57 AM
  3. Emergency URGENT URGENT
    By Abidan in forum Wowza Streaming Engine functionality
    Replies: 1
    Last Post: 07-05-2013, 01:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •