Results 1 to 2 of 2

Thread: Error: RTSPRequestAdapter.getAuthenticationHandler: Unknown method: 0

  1. #1
    Join Date
    Jul 2015
    Posts
    7

    Default Error: RTSPRequestAdapter.getAuthenticationHandler: Unknown method: 0

    Wowza newbie here ... I've only seen a few references to this error on this forum with no real resolution.

    I installed the trial version of Wowza that I have running on my machine. I have written an Android app that connects to this via RTSP socket.

    I have tried to send RTSP ANNOUNCE messages to the server. If I turn off authentication for RTSP in the Wowza Streaming Engine Manager (Applications->live->Incoming Security->Open (No Authentication Required) and also edit the Application.xml file to specify <PublishMethod>none</PublishMethod> and send an ANNOUNCE message, the first time I get a success (200) response. Any messages I send after that (i.e. OPTIONS, SETUP, etc.) show up in the server logs as:

    RTSPRequestAdapter.getAuthenticationHandler: Unknown method: 0

    I have also tried turning on authentication by specifying 'digest' for the <PublishMethod> and turning authentication for RTSP back on, and I get the same response when I send an authenticated ANNOUNCE message using realm, nonce from the response to the 401 Unauthorized message.

    I haven't changed any other settings from what I remember. Does anyone know how to fix this?

  2. #2
    Join Date
    Sep 2011
    Posts
    1,933

    Default

    Hi,
    This will now be handled in the support ticket created (136382).

    Regards,
    Jason

Similar Threads

  1. Unknown log spam on liveedge
    By brambles in forum General Forum
    Replies: 5
    Last Post: 08-22-2013, 09:43 AM
  2. Block connect unknown in Edge
    By Xsplit in forum Server Administration Discussion
    Replies: 2
    Last Post: 01-29-2013, 04:49 PM
  3. Replies: 5
    Last Post: 09-06-2012, 10:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •