Results 1 to 3 of 3

Thread: Wowza can record the live stream but not play it

  1. #1
    Join Date
    Jul 2015

    Default Wowza can record the live stream but not play it

    Now that I solved my fragmentation problem ... I am able to connect to the server via RTSP and initiate an RTP session. Wowza receives all of my packets correctly and I am able to click on the Incoming Streams link of the Live application and see the incoming bytes received incrementing. I can also use the record tool to record the video and when I play it back, it looks perfect.

    However, Wowza refuses to play the stream. I have tried playing with a web player, the engine manager players and VLC. With VLC, I can see the RTSP commands come into the log file where it's setting up the session. The VLC log shows this as well, so I know it's connecting properly. After about 10 seconds, it times out and closes the stream.

    I am running the trial version of Wowza on my PC but we have a license that I plan on migrating to, once this works. All of the TCP and UDP ports are open on my local machine.

    Does anyone know how Wowza works internally? If I have a live application setup, how can I debug this further? I see nothing in the log file that throws any kind of error.

  2. #2



    I am not sure exactly what you are asking. You say the stream plays back, but then you say it does not play back. To me it sounds like you are trying to play the recording, while it is in the process of recording?

    You can view the live stream as live, while recording, but you can not play back the recording will the live stream is still published. Once the live stream is unpublished the recorded file will be created, and then available for VOD playback.

    If this is not what you are having a problem with, can you please explain your issue a bit more?



  3. #3
    Join Date
    Jul 2015


    I can record the live stream using the engine manager record function and play the recorded file back without an issue. I wanted to make sure this worked because I wrote my own encoder.

    I cannot play the live stream. In other words, while my encoder is running, I cannot get anything to connect to the live stream and view it. VLC will make an RTSP connection and initiate the session but has nothing to play back and therefore, will time out.

Similar Threads

  1. can play on local host but not from a remote computer.
    By Joe Hooper in forum Live Streaming and Encoders
    Replies: 1
    Last Post: 02-26-2014, 04:18 PM
  2. Can't play live-record video in iOS device
    By thavasidurai in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 08-11-2013, 08:17 AM
  3. How to choose to record or not to record a live stream with a plugin
    By enricod75 in forum Live Streaming and Encoder Discussion
    Replies: 1
    Last Post: 12-09-2012, 05:53 AM
  4. Nokia Devices and Blacberry cannot play Live stream but Andriod and Iphone can play
    By ravish in forum Live Streaming and Encoder Discussion
    Replies: 3
    Last Post: 09-11-2012, 06:53 AM
  5. H.263(Video)+Nellymoser(Audio) cannot play on demand with rtsp,but can play with rtmp
    By sallyliu in forum Video On Demand Streaming Discussion
    Replies: 4
    Last Post: 12-15-2011, 06:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts