Results 1 to 4 of 4

Thread: Wowza can't see the multicast stream, if it is coming not to default interface

  1. #1
    Join Date
    Aug 2015

    Default Wowza doesn't see the multicast stream, if it is coming not to default interface


    I'm tired from googling and searching the forum regarding the problem when multicast source stream is not on default route interface.
    When multicast source stream is coming to default route interface, then I can see it in wowza engine and everything works fine.
    But suddenly this is not acceptable in my network topology. In my network the multicast source is located in a separate network, so the only way to access it is to connect that network to a secondary network interface on the wowza server.
    But I can't get it working that way...

    I have added lines to vhost.xml


    also have added lines to Application.xml

    </Property> is an address of secondary network interface on the server which is connected to the network where multicast stream is reachable

    also have enabled <RTP><DatagramPortSharing> in Server.xml

    And after those changes, when I connect .stream file with content like udp://, server joins that multicast group on a right interface and with tcpdump I can see that multicast packets are flowing to the server. But Wowza engine still doesn't see that stream.

    What can be wrong, why this stream doesn't reach the wowza application?
    Last edited by kindziulis; 08-31-2015 at 12:12 PM.

  2. Default

    I'm not sure if this is the problem if you say that you do see multicast packets with tcpdump (maybe you see only igmp reports?), but you should have a static route for the multicast source that points over that secondary interface.

    So, if you have eth0 and eth1, and multicast group with multicast source, and this group is available via eth1 interface which has an IP address, then you shoud add e.g. "ip route add via dev eth1".

  3. #3
    Join Date
    Aug 2015


    Thank you SiggDev, you have solved my problem. My fault was - that I have added a static route for multicast ( ip route add -net via ... ), not for multicast source address .

  4. Default

    I'm glad I could help. Good luck with your setup.

Similar Threads

  1. wowza can support http in comming streaming
    By abourawash in forum General Forum
    Replies: 1
    Last Post: 07-08-2014, 08:06 AM
  2. Multicast on fixed network interface
    By Lelik1985 in forum General Forum
    Replies: 2
    Last Post: 01-28-2012, 08:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts