Results 1 to 7 of 7

Thread: Configure Wowza with two network interface (multicast and internet)

  1. #1

    Default Configure Wowza with two network interface (multicast and internet)

    Hi Guys,

    Currently I have a CentOS 6.6 server with two network interfaces, configure CentOS to query the multicast right through the eth1 interface and eth0 is a public IP Internet.

    Destination Gateway Genmask Flags Metric Ref Use Iface
    189.211.x.x 0.0.0.0 255.255.255.0 U 1 0 0 eth0
    10.163.128.0 0.0.0.0 255.255.128.0 U 1 0 0 eth1
    224.0.0.0 10.163.128.1 240.0.0.0 UG 0 0 0 eth1
    0.0.0.0 189.211.x.x 0.0.0.0 UG 0 0 0 eth0

    The server with this configuration can access the multicast from the eth1 and play the video in VLC without any problem and from the eth0 interface can browse the Internet.

    Wowza in force in the host file that is the ip eth0.
    What I want to achieve with the Wowza is that the eth1 interface that is accessing the multicast may transmit it to the public IP.

    Try setting my Wowza but does not play the video. if I make a request to link incoming RTP and revised the data streaming if reciviendo

    join to udp://@239.232.x.x:5001

    Network Throughput

    In Bytes: 20291875128 @ 2.980 Mbits / s

    Bytes Out: 0 @ 0,000 bits / s

    But if I connect with the VLC makes the connection but no video or audio.

    Any idea how to set my Wowza?
    Last edited by irreverentezradio; 09-15-2015 at 07:46 AM.

  2. #2

    Default

    Hello there.

    Please take a look at this forum post and see if it answers your question:
    Wowza with two network interfaces?

    If not can you please explain what you are trying to do exactly.

    Regards,

    Salvadore

  3. #3

    Default

    I have a server with Centos 6.7 in which I have 2 network interfaces are:

    eth0: This interface is connected to the Internet is a public ip like:
    189.211.X.X

    eth1: This interface is connected to a private network, this network is configured a multicast network and have assigned the ip:
    10.163.135.39

    I want to achieve with the Wowza connect to multicast streaming in this case "udp: //@239.232.xx: 5001" that this network is only available for the private network "eth1" and want to generate a public network restreaming "eth0 "" rtmp: //189.211.XX: 1935 / axt / barker.stream "

    What I've done:

    I set centos to RECEIVE the multicast traffic only from the eth1 and all other IP traffic defined by the public as shown:

    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    189.211.X.0 0.0.0.0 255.255.255.0 U 1 0 0 eth0
    10.163.128.0 0.0.0.0 255.255.128.0 U 1 0 0 eth1
    224.0.0.0 10.163.128.1 240.0.0.0 UG 0 0 0 eth1
    0.0.0.0 189.211.X.X 0.0.0.0 UG 0 0 0 eth0

    In the Wowza I created an application called "axt" and stream file "barker.stream" which links to the following ip "udp: //@239.232.199.14: 5001".

    In the [install-dir] /conf/VHost.xml the parameter was modified:
    <IpAddress> 189.211.X.X </ IpAddress>

    <MulticastBindToAddress> true </ MulticastBindToAddress>
    <MulticastInterfaceAddress> 10.163.135.39 </ MulticastInterfaceAddress>

    agrege also file [install-dir] /conf/axt/Application.xml the following information:

    <Property>
    <Name> multicastInterfaceAddress </ Name>
    <Value> 10.163.135.39 </ Value>
    </ Property>

    With all this configured consult the link service from the application VLC:

    rtmp: //189.211.21.X: 1935 / axt / barker.stream

    Starts loading and then time begins to advance Transmit however I have no picture or audio.

    Any idea what's wrong with my setup?

    Note: If I check multicast directly from the VLC I can see the video without any problem:
    udp: //@239.232.199.14: 5001

  4. #4

    Default

    Quote Originally Posted by salvadore View Post
    Hello there.

    Please take a look at this forum post and see if it answers your question:
    Wowza with two network interfaces?

    If not can you please explain what you are trying to do exactly.

    Regards,

    Salvadore
    any idea ?

  5. #5
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hi,

    In the [install-dir] /conf/VHost.xml can you try changing <IpAddress>189.211.X.X</ IpAddress> with <IpAddress>*</ IpAddress>?
    You will need to restart your Wowza Streaming Engine service so that the new modification can be applied.

    Zoran

  6. #6

    Default

    Quote Originally Posted by zoran_u View Post
    Hi,

    In the [install-dir] /conf/VHost.xml can you try changing <IpAddress>189.211.X.X</ IpAddress> with <IpAddress>*</ IpAddress>?
    You will need to restart your Wowza Streaming Engine service so that the new modification can be applied.

    Zoran
    Hi,

    I changed the ip to * but still have the problem:

    I changed the ip to * but still have the problem:

    Source stream or file Could not be found or access was denied.

    in the test player

    http://www.wowza.com/testplayers

    Any other ideas?

  7. #7

    Default

    I see you have multiple forum threads with the same unresolved issue. Perhaps it would be best to open a ticket at this point.

    Please zip the following folders and send them to support@wowza.com to open a ticket:
    [install-dir]/conf
    [install-dir]/logs
    [install-dir]/transcoder
    [install-dir]/manager/logs


    Regards,

    Salvadore

Similar Threads

  1. I need help with configuration multicast in server with two network interface
    By irreverentezradio in forum Live Streaming and Encoders
    Replies: 3
    Last Post: 09-24-2015, 06:48 AM
  2. Wowza Live Stream Visible on Local Network But Not Over Internet ?
    By telcoray in forum Live Streaming and Encoders
    Replies: 4
    Last Post: 05-22-2015, 08:50 AM
  3. Multicast on fixed network interface
    By Lelik1985 in forum General Forum
    Replies: 2
    Last Post: 01-28-2012, 08:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •