Results 1 to 7 of 7

Thread: Wowza Streaming Engine 4.2 and ubuntu 15.04 with Systemd

  1. #1

    Default Wowza Streaming Engine 4.2 and ubuntu 15.04 with Systemd

    Hi everybody,

    I'm currently using Wowza with ubuntu 15.04 wich use the new service startup system (systemd) and i can't have wowza to start automaticaly.

    I have seen this post (http://www.wowza.com/forums/showthre...-error-message) and the workaround but i would like to know if Wowza is planning to support systemd?

    alternatively is there a way to configure systemd to start wowza?

    Best regards

    Richard

  2. #2
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi,
    We are planning to support systemd, but there is not timeframe for availability.

    Best regards,
    Daren

  3. #3

    Default

    Quote Originally Posted by daren_j View Post
    Hi,
    We are planning to support systemd, but there is not timeframe for availability.

    Best regards,
    Daren
    Thank you for your answer,

    Is there any temporary workaround available? I tried to build a custom .service file but without success.

    Best regards

    Richard

  4. #4
    Join Date
    Jun 2011
    Posts
    1,047

    Default

    Hi
    There are some workarounds.

    1/ you can manually start Wowza by running the following as root

    # /etc/init.d/WowzaStreamingEngine start

    # /etc/init.d/WowzaStreamingEngineManager start

    2/ Alternatively, you can reinstall the missing upstart functionality

    # apt-get install upstart-sysv

    The second option would ensure that Wowza is restarted on machine reboots.

    3) A third option would be to try implementing the systemd service. This forum thread/post seems to have something that was reported as working.

    Daren

  5. #5

    Default

    Quote Originally Posted by daren_j View Post
    Hi
    There are some workarounds.

    1/ you can manually start Wowza by running the following as root

    # /etc/init.d/WowzaStreamingEngine start

    # /etc/init.d/WowzaStreamingEngineManager start

    2/ Alternatively, you can reinstall the missing upstart functionality

    # apt-get install upstart-sysv

    The second option would ensure that Wowza is restarted on machine reboots.

    3) A third option would be to try implementing the systemd service. This forum thread/post seems to have something that was reported as working.

    Daren
    1) Is the solution i currently use.... but it is not very safe in production situation.

    2) I tried this but the rollback to upstart give me some weirf behavior of my web server..

    3) I just tried this solution and i receive the following error message when trying to activate the service :

    administrateur@zircone:/etc/init.d$ sudo systemctl enable WowzaStreamingEngine.service 
    Synchronizing state for WowzaStreamingEngine.service with sysvinit using update-rc.d...
    Executing /usr/sbin/update-rc.d WowzaStreamingEngine defaults
    insserv: warning: current stop runlevel(s) (0 1 6) of script `WowzaStreamingEngine' overrides LSB defaults (0 1 6 S).
    Executing /usr/sbin/update-rc.d WowzaStreamingEngine enable
    update-rc.d: error: WowzaStreamingEngine Default-Start contains no runlevels, aborting.

  6. #6

    Default

    It's ok it works.

    I just forgot :

    removed symlink /etc/init.d/WowzaStreamingEngine
    removed symlink /etc/init.d/WowzaStreamingEngineManager
    Best regards

    Richard

  7. #7

    Default

    Thanks for the update and glad you got this sorted.

    Salvadore

Similar Threads

  1. WowzaStreamingEngine not starting with systemd
    By broaska in forum General Forum
    Replies: 9
    Last Post: 06-01-2015, 01:05 AM
  2. Replies: 0
    Last Post: 05-09-2014, 01:52 PM
  3. QuickSync, XAuthority, and Ubuntu 12.04.3
    By KLindgren in forum AddOn: Transcoder
    Replies: 1
    Last Post: 12-13-2013, 12:49 PM
  4. Replies: 3
    Last Post: 12-06-2011, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •