Results 1 to 2 of 2

Thread: Akamai Multi Bitrate Live Application Issue

  1. #1
    Join Date
    Sep 2015

    Default Akamai Multi Bitrate Live Application Issue


    I'm using Wowza Streaming Engine 4.1.1 to send several different bitrates to Akamai. Here's my PushPublishMap.txt:

    client3Low={profile:"rtmp-akamai", streamName:"rebroadcastpro_1_500", akamai.streamId:310801, userName:"user_name", password:"secret_pw", debugLog:true, adaptiveStreaming:true}
    client3Med={profile:"rtmp-akamai", streamName:"rebroadcastpro_1_1500", akamai.streamId:310801, userName:"user_name", password:"secret_pw", debugLog:true, adaptiveStreaming:true}

    and my SMIL:


    <stream name="client3Low"></stream>
    <stream name="client3Med"></stream>

    <playlist name="" playOnStream="client3Low" repeat="true" scheduled="2015-09-15 00:00:00">
    <video src="mp4:bigbuck-350k.mp4" start="0" length="600"/>
    <playlist name="" playOnStream="client3Med" repeat="true" scheduled="2015-09-15 00:00:00">
    <video src="mp4:bigbuck-900k.mp4" start="0" length="600"/>


    With a single bitrate I was able to edit my SMIL and use the schedule loader (by pinging to load my new video successfully.

    With multiple bitrates as shown above I have to restart my application in order for the video to play back correctly at different bitrates. As you can see here ( the first bitrate will usually load fine, but when switching (there is an option in the second column of checkboxes at the top to use manual switching. the two buttons to the right of that option allow you to step up or down. the "Index being rendered" will indicate when the change is being rendered in the player) the other videos freeze up and distort.

    Any thoughts on what could be going on here? Restarting the application will allow all bitrates to play back without any issues, but that's really not a great option since it will cut any current viewers off.

    Any help is greatly appreciated!

  2. #2


    Hello there. This could be an issue with key frame alignment. How are you generating the ABR set of streams?

    You can use this guide to debug keyframe alignment:
    How to debug encoder multi-bitrate keyframe alignment



Similar Threads

  1. multi-bitrate playing issue
    By ehuman in forum AddOn: Transcoder
    Replies: 1
    Last Post: 12-19-2011, 12:48 PM
  2. Issue with multi-bitrate vod smil files
    By Padre2k in forum Video On Demand Streaming Discussion
    Replies: 3
    Last Post: 11-20-2011, 07:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts