Results 1 to 6 of 6

Thread: Wowza not accepting mp3 audio

  1. #1

    Default Wowza not accepting mp3 audio

    HI


    Using ffmpeg , I am converting HLS audio stream to RTMP But Wowza is not accepting mp3 format. It streams the audio only when i encode the hls stream to aac.


    ffmpeg -i hls_stream-url -f mp3 rtmp://wowza-server-ip/live/audioStream -> Not Working

    ffmpeg -i hls_stream-url -c:a aac -strict -2 -f flv rtmp://wowza-server-ip/live/audioStream -> working

    Please advise.

    Thanks

  2. #2
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    Please post an example of the URL you're using for playback (using [Wowza-IP-Address] to hide the IP address if required]
    By default Wowza will use the mp4: prefix and you may need to change this to mp3: if it's an audio only stream.

    Are you seeing any issues within the log files when the stream is being published?

    Regards,
    Jason

  3. #3

    Default

    I gave this cmd: ffmpeg -i [hls-stream-url] -f mp3 rtmp://[wowza-server-ip]/live/audioStream

    and tried to save the file on Wowza..Wowza creates just 1kb file
    and after few seconds the audiostream closes on its own on Wowza server whereas my ffmpeg is still streaming the audio.

    I use rtmp://[wowza-server-ip]/live/audioStream to play the audio in vlcplayer

    Following is the Wowza log during this test:-

    2015-10-03 14:06:32 IST app-start application INFO 200 _definst_ live/_definst_ - - - 1087.251 - - - - - - - - - - - - - - - - - - - - - - - - -
    2015-10-03 14:06:32 IST connect-pending session INFO 100 192.168.0.115 - _defaultVHost_ live _definst_ 0.407 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3179 3073 - - - - - - - - - - - - - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:06:32 IST connect session INFO 200 192.168.0.115 - _defaultVHost_ live _definst_ 0.412 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3179 3073 - - - - - - - - - - - - - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:06:32 IST create stream INFO 200 - - _defaultVHost_ live _definst_ 0.039 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3304 3413 1 0 0 0 - - - - - - rtmp://192.168.0.115:1935/live rtmp://192.168.0.115:1935/live - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:06:32 IST publish stream INFO 200 audiostream - _defaultVHost_ live _definst_ 0.055 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3357 3609 1 0 0 0 audiostream - - - - - rtmp://192.168.0.115:1935/live/audiostream rtmp://192.168.0.115:1935/live/audiostream - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:07:05 IST comment session INFO 401 1344473653 client connectionClosed [1344473653] pingtimeout _defaultVHost_ live _definst_ 32.69 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3357 3788 - - - - - - - - - - - - - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:07:05 IST unpublish stream INFO 200 audiostream - _defaultVHost_ live _definst_ 32.259 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3357 3788 1 0 0 0 audiostream - - - - - rtmp://192.168.0.115:1935/live/audiostream rtmp://192.168.0.115:1935/live/audiostream - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:07:05 IST destroy stream INFO 200 audiostream - _defaultVHost_ live _definst_ 32.261 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3357 3788 1 0 0 0 audiostream - - - - - rtmp://192.168.0.115:1935/live/audiostream rtmp://192.168.0.115:1935/live/audiostream - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:07:05 IST disconnect session INFO 200 1344473653 - _defaultVHost_ live _definst_ 32.695 [any] 1935 rtmp://192.168.0.115:1935/live 192.168.0.115 rtmp - unknown 1344473653 3357 3788 - - - - - - - - - - - - - rtmp://192.168.0.115:1935/live -
    2015-10-03 14:08:05 IST app-stop application INFO 200 _definst_ live/_definst_ - - - 1179.976 - - - - - - - - - - - - - - - - - - - - - - - - -

    Thanks.



    Quote Originally Posted by JasonH View Post
    Hi,
    Please post an example of the URL you're using for playback (using [Wowza-IP-Address] to hide the IP address if required]
    By default Wowza will use the mp4: prefix and you may need to change this to mp3: if it's an audio only stream.

    Are you seeing any issues within the log files when the stream is being published?

    Regards,
    Jason

  4. #4
    Join Date
    Sep 2011
    Posts
    1,934

    Default

    Hi,
    The log is showing a 401 (Unauthorized) message
    2015-10-03	14:07:05	IST	comment	session	INFO	401	1344473653	client connectionClosed [1344473653] pingtimeout	_defaultVHost_	live	_definst_	32.69	[any]	1935	rtmp://192.168.0.115:1935/live	192.168.0.115	rtmp	-	unknown 1344473653	3357	3788
    I recommend removing authentication to see if you're getting the same results when a username/password isn't required.
    For authentication of publishers which don't support the username/password authentication popup, you can replace this authentication method with our ModuleSecureURLParams authentication Module.

    Regards,
    Jason

  5. #5

    Default

    Quote Originally Posted by JasonH View Post
    Hi,
    The log is showing a 401 (Unauthorized) message
    2015-10-03	14:07:05	IST	comment	session	INFO	401	1344473653	client connectionClosed [1344473653] pingtimeout	_defaultVHost_	live	_definst_	32.69	[any]	1935	rtmp://192.168.0.115:1935/live	192.168.0.115	rtmp	-	unknown 1344473653	3357	3788
    I recommend removing authentication to see if you're getting the same results when a username/password isn't required.
    For authentication of publishers which don't support the username/password authentication popup, you can replace this authentication method with our ModuleSecureURLParams authentication Module.

    Regards,
    Jason
    I tried without authentication and also using ModuleSecureURLParams. aac is working, but mp3 is not....

    ffmpeg -i hls_stream-url -f mp3 rtmp://wowza-server-ip/live?doPublish=12345/audioStream -> Not Working

    ffmpeg -i hls_stream-url -c:a aac -strict -2 -f flv rtmp://wowza-server-ip/live?doPublish=12345/audioStream -> working

    Do we need some other module/property to enable it in Wowza server to accept mp3 audio input?

  6. #6
    Join Date
    Jun 2012
    Posts
    723

    Default

    Hello,

    Do you get the same issue when using a different encoder?

    Zoran

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •