Results 1 to 4 of 4

Thread: Tutorial request - Winnov CBox P3 / RTMP

  1. #1
    Join Date
    Dec 2015
    Posts
    6

    Default Tutorial request - Winnov CBox P3 / RTMP

    Hello,

    I am looking for a tutorial or correct instructions on streaming a Winnov CBox P3 live feed to be ingested into our Wowza streaming media server using RTMP to play in JW Player.

    Unfortunately, I cannot provide a link to our website due to client restrictions.

    Assuming all communications between the Winnov CBox and Wowza in place, on default port 1935..

    I have the Wowza server set up and working fine with RTMP / VOD. Our client also wants live streaming / record capability.

    In Wowza, I have created a source authentication username and password. I have a live application as well. While in the live application properties, I have selected "Sources (Live) and the Winnov CBox P3 is not there, it unfortunately appears to be an "Other encoder".

    I would then set up the Winnov encoder with the Application connections settings listed under Sources Live with correct IP, port 1935, application name, my selected stream name and the username and password of the source authentication I had previously created.

    At this point, I'm not quite sure where I go from here. If the Winnov CBox is configured correctly to stream the live feed to our Wowza server, I would except to see that feed being ingested and showing up in the "Incoming Streams" tab in the live Wowza application. Would that be correct?

    Any help is much appreciated.

  2. #2
    Join Date
    Jan 2016
    Posts
    3

    Default

    Hi bpetrow,

    I hope this finds you well. I don't have a Winnov P3 system to test this out and there isn't much information 'online' out there on these devices in terms of manuals etc.

    Your assumption is correct, you should be able to see the feed on the "Incoming Streams". There are a list of things you could try and do to troubleshoot this

    - Look for any errors on the Winnov user interface. I am not aware of how it displays if it is streaming successfully or unsuccessfully. (I am going to assume it all looks fine on this device hence why you have put forward the question). From what I gather from an older winnov device video on Youtube the record button records and it sends the stream also and flashes red?
    - Check the logs on the Winnov CBox to see if it is actually establishing a connection to your Wowza server. That is if the system generates log files with connection/streaming data that are easily accessible.
    - Check the logs on the Wowza server. If the Winnov is talking to your Wowza server it will be recording the information in the log files. If you are sending the stream and checking the Wowza logs at the same time and nothing appears in the logs, it might be that something is malconfigured or the Winnov box cannot reach the Wowza server destination via the network/Internet. You you are running Wowza Streaming Engine 4.1.1 or above you can find out how to view the log files here
    - If you have a relatively new android/iOS device you could try installing the Wowza GoCoder app (which is brilliant BTW) and send a stream to your Wowza server. You can find a helpful article here to guid eyou through the setup. If the GoCoder app works then your Wowza server is working and accepting incoming streams. If the GoCoder app connects fine you'll be able to see what it looks like on the "Incoming Streams" page when everything is working fine.

    Pretty generic troubleshooting above as without knowing your network configurations, servers, the Winnov device etc I can't really get to specific/detailed.

    Please do let me know if I can help you further. More than happy to help.

    Good luck!
    Matt

  3. #3
    Join Date
    Dec 2015
    Posts
    6

    Default

    Quote Originally Posted by matthewd View Post
    Hi bpetrow,

    I hope this finds you well. I don't have a Winnov P3 system to test this out and there isn't much information 'online' out there on these devices in terms of manuals etc.

    Your assumption is correct, you should be able to see the feed on the "Incoming Streams". There are a list of things you could try and do to troubleshoot this

    - Look for any errors on the Winnov user interface. I am not aware of how it displays if it is streaming successfully or unsuccessfully. (I am going to assume it all looks fine on this device hence why you have put forward the question). From what I gather from an older winnov device video on Youtube the record button records and it sends the stream also and flashes red?
    - Check the logs on the Winnov CBox to see if it is actually establishing a connection to your Wowza server. That is if the system generates log files with connection/streaming data that are easily accessible.
    - Check the logs on the Wowza server. If the Winnov is talking to your Wowza server it will be recording the information in the log files. If you are sending the stream and checking the Wowza logs at the same time and nothing appears in the logs, it might be that something is malconfigured or the Winnov box cannot reach the Wowza server destination via the network/Internet. You you are running Wowza Streaming Engine 4.1.1 or above you can find out how to view the log files here
    - If you have a relatively new android/iOS device you could try installing the Wowza GoCoder app (which is brilliant BTW) and send a stream to your Wowza server. You can find a helpful article here to guid eyou through the setup. If the GoCoder app works then your Wowza server is working and accepting incoming streams. If the GoCoder app connects fine you'll be able to see what it looks like on the "Incoming Streams" page when everything is working fine.

    Pretty generic troubleshooting above as without knowing your network configurations, servers, the Winnov device etc I can't really get to specific/detailed.

    Please do let me know if I can help you further. More than happy to help.

    Good luck!
    Matt
    Thanks for the reply Matt, it ended up being a firewall blocking the connection, I now have a good working stream going. Thank you VERY much for the reply. I do appreciate it.

  4. #4
    Join Date
    Jan 2016
    Posts
    3

    Default

    You are most welcome. That's great it is all working for you now. Well done and happy Streaming!

Similar Threads

  1. Per-request request/response logging similar to Tomcat
    By mtownsend in forum Video On Demand Streaming Discussion
    Replies: 5
    Last Post: 07-28-2015, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •