Results 1 to 2 of 2

Thread: Error message for Media cache on caption

  1. #1
    Join Date
    Dec 2015
    Posts
    10

    Default Error message for Media cache on caption

    Hi,

    I'm working on add TTML subtitle for HLS vod streaming on wowza engine.

    So far we are using Wowza engine 4.4 and HLS v4.

    The subtitle is added in SMIL file like following :

    <?xml version="1.0"?>
    <smil>
    	<head/>
    	<body>
    		<switch>
    			<video src="mp4:000000717117.mp4?audioindex=0" system-language="Cantonese" title="Cantonese" audio-bitrate="48000">
    				<param name="audioOnly" value="TRUE" valuetype="data"/>
    				<param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    				<param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    				<param name="cupertinoTag.DEFAULT" value="YES" valuetype="data"/>
    			</video>
    			<video src="mp4:000000717117.mp4?audioindex=1" system-language="Mandarin" title="Mandarin" audio-bitrate="48000">
    				<param name="audioOnly" value="TRUE" valuetype="data"/>
    				<param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    				<param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    				<param name="cupertinoTag.DEFAULT" value="YES" valuetype="data"/>
    			</video>
    			<video src="000000717117.mp4" system-bitrate="1404000">
    				<param name="videoOnly" value="TRUE" valuetype="data"/>
    				<param name="cupertinoTag.AUDIO" value="aac" valuetype="data"/>
    			</video>
    			<textstream src="215881.ttml" system-language="eng,zho">
    				<param name="isWowzaCaptionStream" value="true"/>
    			</textstream>
    		</switch>
    	</body>
    </smil>
    The Application conf file code related :
                    <TimedText>
                            <!-- VOD caption providers (separate with commas): vodcaptionprovidermp4_3gpp, vodcaptionproviderttml, vodcaptionproviderwebvtt,  vodcaptionprovidersrt, vodcaptionproviderscc -->
                            <VODTimedTextProviders>vodcaptionproviderttml</VODTimedTextProviders>
                            <!-- Properties for TimedText -->
                            <Properties>
                                    <Property>
                                            <Name>cupertinoVODCaptionsUseWebVTT</Name>
                                            <Type>Boolean</Type>
                                            <Value>true</Value>
                                    </Property>
                            </Properties>
                    </TimedText>
    I find some error messages in access log :
    ERROR   server  comment 2016-02-17      15:07:34        -       -       -       -       -       0.752   -       -       -       -       -       -       -       -       MediaCacheItemFile.init (/data/wowza/content/vipo/he9/4979/497858/000000717117.ttml) : java.io.FileNotFoundException: /data/wowza/content/vipo/he9/4979/497858/000000717117.ttml (No such file or directory)|at java.io.RandomAccessFile.open0(Native Method)|at java.io.RandomAccessFile.open(RandomAccessFile.java:316)|at java.io.RandomAccessFile.<init>(RandomAccessFile.java:243)|at com.wowza.io.WowzaRandomAccessFile.<init>(WowzaRandomAccessFile.java:12)|at com.wowza.wms.mediacache.impl.MediaCacheItemFileImpl.init(MediaCacheItemFileImpl.java:209)|
    WARN    server  comment 2016-02-17      15:07:34        -       -       -       -       -       0.755   -       -       -       -       -       -       -       -       MediaCacheItemBase.init: Item does not exist: vipo/he9/4979/497858/000000717117.ttml
    And the link we use is : http://[HOSTNAME]/vipo/_definst_/smil:vipo/he9/4979/497858/mps_000000717117.smil/playlist.m3u8

    As we have a cache source at /data/wowza/content/vipo/, I think wowza server added 000000717117.ttml as default ttml while the actual ttml file is named 215881.ttml. As a result, Media cache cannot find the subtitle file so the error message appeared.

    Is there a way to disable this message?
    Or is there a way to add the real ttml file path to wowza? I've tried captionFileNamingRule and captionPathNamingRule but I'm not sure the value. The ttml file is at the same folder with mp4 file, but the file name are different.

    Thanks,
    Monica
    Last edited by monica; 02-17-2016 at 02:47 AM.

  2. #2

    Default

    Hi Monica,

    Wowza will automatically look for a closed caption file that is the filename.[caption-extension]. If it doesn't exist it may log that fact. This is normal and you can ignore those messages if you don't actually have any filename.caption files. Wowza should use the textstream source in the smil defintion so long as the file exists and is locatable (basically place it in the place as your smil file).



    Paul

Similar Threads

  1. Media Cache forcing /Media/
    By Mallanon in forum Server Administration
    Replies: 4
    Last Post: 10-23-2014, 09:57 AM
  2. Playlist, chunklist - Cache-control: no-cache
    By mcaron in forum Server-side Modules and Code Samples Discussion
    Replies: 0
    Last Post: 06-18-2012, 04:18 AM
  3. Replies: 3
    Last Post: 02-07-2012, 12:49 AM
  4. Replies: 1
    Last Post: 01-03-2012, 03:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •