Results 1 to 4 of 4

Thread: Skipping in mp3 files is inexact

  1. #1

    Default Skipping in mp3 files is inexact

    Hi,

    We're using Wowza to stream from some very long mp3 files (24 hours).

    When we skip in these files, the timing is slightly off (consistently about 0.137 sec/minute). This seems to be an issue with ffmpeg, since the behaviour is the same using ffmpeg from the command line. So we want to skip in the stream by actually rendering the output and going there.

    We tried setting the "seekTarget" property to "enhanced", since we understood that that should be the effect of that setting. But it seems to have no effect.

    diff --git a/wowza_vhost_cosound/conf/chaos/Application.xml b/wowza_vhost_cosound/conf/chaos/Application.xml
    index f25382a..e2cee71 100644
    --- a/wowza_vhost_cosound/conf/chaos/Application.xml
    +++ b/wowza_vhost_cosound/conf/chaos/Application.xml
    @@ -38,6 +38,10 @@
                            <LiveStreamPacketizers></LiveStreamPacketizers>
                            <!-- Properties defined here will override any properties defined in conf/Streams.xml for any streams types loaded by this application -->
                            <Properties>
    +                               <Property>
    +                                       <Name>seekTarget</Name>
    +                                       <Value>enhanced</Value>
    +                               </Property>
                            </Properties>
                    </Streams>
                    <Transcoder>
    Is there some way we can get exact skipping in mp3-streams in Wowza?

    Thank you.

    Best,
    Kåre

  2. #2

    Default

    Hi,

    Yes seekTarget is really only for RTMP streams. It can be set to audio as well as enhanced and videoKeyFrame, so you could try that, but no guarantees it would improve things with MP3 files.


    Paul

  3. #3

    Default

    Thank you.

    Since the seeking is off in both http- and rtmp-streams it seems this setting is not related. I'm unsure exactly where I should have put the property in the Application.xml-file though, even if I wanted to.

    I am now experimenting with the solution from here, which seems to give better results:

    https://www.wowza.com/forums/content...ation-accuracy

  4. #4

    Default

    Hi,

    Yes that can provide better results but be aware that it may cause more overhead the smaller the value. We have heard of good results reported in the past with it set as low as 50, so feel free to try setting this and see if it helps.


    Paul

Similar Threads

  1. Replies: 2
    Last Post: 01-13-2015, 03:20 AM
  2. VOD RTMP via EC2 & S3 - Does seeking (time-shifting/skipping ahead) work?
    By robotstream in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 1
    Last Post: 09-25-2013, 03:13 PM
  3. hls skipping redownloads chunk
    By arpan_synapse in forum Performance Tuning Discussion
    Replies: 1
    Last Post: 08-06-2013, 03:41 AM
  4. Replies: 1
    Last Post: 07-27-2012, 02:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •