Results 1 to 6 of 6

Thread: Only Private IP listed

  1. #1
    Join Date
    Mar 2015
    Posts
    26

    Default Only Private IP listed

    I have created multiple test servers using Azure VM/ Wowza

    The issue I am having only the private 10. address is available:

    Application Connection Settings

    Use the following settings to publish a stream to Wowza Streaming Engine:

    Host - Server
    10.2.0.4

    Host - Port
    1935

    I cannot connect wirecast to the IP information provided. I have a public IP when the Azure VM was created, I can navigate to the WSEM using the public IP but only the 10. address is listed as the Host Server.

    Why is that and how do I correct it?

    Thanks

  2. #2

    Default

    Hello,

    You may want to look into setting up an Azure VM Endpoint to allow access from the Public IP address.

    Best regards,
    Andrew

  3. #3
    Join Date
    Mar 2015
    Posts
    26

    Default

    I created a new VM running Windows Server 2012 I can get to the WSE using dnsname:8088/enginemanager and public IP:8088/enginemanager and can access WSE just fine.

    However, the private IP is stuck in the Application Connection Settings

    I can run the test player which has the 10. IP address by default and the sample video doesn't play, If I switch the IP to the public it will play the sample file (Big Buck Bunny).

    The question I have where do I change the private IP to the public so I can connect my encoder to the right IP. I have set test VMs without the private IP getting in the way before.

    Use the following settings to publish a stream to Wowza Streaming Engine:

    Host - Server
    10.11.0.4 (Private IP Address)

    Host - Port
    1935

  4. #4

    Default

    Hello,

    Modifying the following IP Address and Port information your VHost.xml file will update the IP Address shown in the Manager and Test Player. This may give you the results you're looking for.
    		<Manager>
    			<TestPlayer>
    				<IpAddress>[Servers' Public IP Address]</IpAddress>
    				<Port>1935</Port>
    				<SSLEnable>${com.wowza.wms.HostPort.SSLEnable}</SSLEnable>
    			</TestPlayer>
    			<!-- Properties defined are used by the Manager -->
    			<Properties>
    			</Properties>
    		</Manager>
    Best regards,
    Andrew

  5. #5
    Join Date
    Mar 2015
    Posts
    26

    Default

    Andrew,

    That resolved the issue thanks....

    Do you know why Azure would use the private address , when using previous VM I never had this issue.

  6. #6

    Default

    Hello,

    This is a known issue and will likely be resolved in the future. These problems are caused by the way in which Azure Marketplace processes variable lookup metadata.

    Best regards,
    Andrew

Similar Threads

  1. Only private IP address is shown
    By shueardm in forum GoCoder Encoding App
    Replies: 2
    Last Post: 04-04-2014, 06:17 AM
  2. Authentication for accessing private S3 files not working
    By amagee in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 14
    Last Post: 05-29-2012, 01:28 PM
  3. Codec Private Data missing
    By german in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 12-08-2011, 11:07 AM
  4. Configuration options are they listed anywhere
    By iatanasov in forum General Forum
    Replies: 2
    Last Post: 11-18-2011, 07:15 AM
  5. RTSP video on amazon s3 private
    By Carlos Eduardo in forum General Forum
    Replies: 8
    Last Post: 10-28-2011, 01:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •