Results 1 to 5 of 5

Thread: Stuck with Private Server IP address

  1. #1
    Join Date
    Mar 2015
    Posts
    26

    Default Stuck with Private Server IP address

    I created a new WSE server using the Wowza VM for AZURE.

    I created a public IP address and I can navigate to the public IP and I see the following:

    Wowza Streaming Engine 4 for Microsoft Azure 4.1.2 build13947


    I cannot navigate to publicIP:8088/enginemanager
    This page canít be displayed

    on the VM I can navigate locally and I see the following

    Connection Settings

    Use the following settings to publish a stream to Wowza Streaming Engine:

    Server IP
    10.6.0.4

    Port
    1935

    Application A live application name on this server
    Stream Name The stream name you want to use
    Login A valid Publisher user name and password

    In previous VMs I created I did not have this issue the public IP was listed instead of the private.

    Where do I go to change the private IP to the public IP so I can connect the encoder and players to the streaming engine.

    Also what changed I have created several test servers and never had this issue. I have looked at the help videos and looked over the documentation and I don't see what I am doing wrong.

    Also what has changed? I never had this issue before last week.

    Thanks

  2. #2
    Join Date
    Apr 2016
    Posts
    3

    Default

    Quote Originally Posted by ebandu View Post
    I created a new WSE server using the Wowza VM for AZURE.

    I created a public IP address and I can navigate to the public IP and I see the following:

    Wowza Streaming Engine 4 for Microsoft Azure 4.1.2 build13947


    I cannot navigate to publicIP:8088/enginemanager
    This page canít be displayed

    on the VM I can navigate locally and I see the following

    Connection Settings

    Use the following settings to publish a stream to Wowza Streaming Engine:

    Server IP
    10.6.0.4

    Port
    1935

    Application A live application name on this server
    Stream Name The stream name you want to use
    Login A valid Publisher user name and password

    In previous VMs I created I did not have this issue the public IP was listed instead of the private.

    Where do I go to change the private IP to the public IP so I can connect the encoder and players to the streaming engine.

    Also what changed I have created several test servers and never had this issue. I have looked at the help videos and looked over the documentation and I don't see what I am doing wrong.

    Also what has changed? I never had this issue before last week.

    Thanks
    If Wowza is installed on Ubuntu, possibly you need to edit /etc/network/interfaces file for "eth0, eth1"

  3. #3

    Default

    Hello,

    It sounds like your public IP is setup properly for port 80 traffic. You may want to look into setting up endpoints to allow port the common Wowza ports to pass-through to your internal IP address. (TCP 554,1935,8086-8088)

    Best regards,
    Andrew

  4. #4
    Join Date
    Mar 2015
    Posts
    26

    Default

    Andrew thanks for the reply.

    I seem to have resolved that issue but the problem of the private IP remains.

    I created a new VM running Windows Server 2012 I can get to the WSE using dnsname:8088/enginemanager and public IP:8088/enginemanager and can access WSE just fine.

    However the private IP is stuck in the Application Connection Settings

    I can run the test player which has the 10. IP address by default and the sample video doesn't play, If I switch the IP to the public it will play the sample file (Big Buck Bunny).

    The question I have where do I change the private IP to the public so I can connect my encoder to the right IP. I have set test VMs without the private IP getting in the way before.

    Use the following settings to publish a stream to Wowza Streaming Engine:

    Host - Server
    10.11.0.4 (Private IP Address)

    Host - Port
    1935



    Quote Originally Posted by andrew_r View Post
    Hello,

    It sounds like your public IP is setup properly for port 80 traffic. You may want to look into setting up endpoints to allow port the common Wowza ports to pass-through to your internal IP address. (TCP 554,1935,8086-8088)

    Best regards,
    Andrew

  5. #5

Similar Threads

  1. Only private IP address is shown
    By shueardm in forum GoCoder Encoding App
    Replies: 2
    Last Post: 04-04-2014, 06:17 AM
  2. Authentication for accessing private S3 files not working
    By amagee in forum Wowza Media Server 3 for Amazon EC2 Discussion
    Replies: 14
    Last Post: 05-29-2012, 01:28 PM
  3. Codec Private Data missing
    By german in forum Video On Demand Streaming Discussion
    Replies: 1
    Last Post: 12-08-2011, 11:07 AM
  4. RTSP video on amazon s3 private
    By Carlos Eduardo in forum General Forum
    Replies: 8
    Last Post: 10-28-2011, 01:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •