Results 1 to 3 of 3

Thread: Moving content folder to a different volume

  1. #1
    Join Date
    Mar 2016

    Default Moving content folder to a different volume

    I have what I assume is a silly problem...

    I have a server installed on AWS, default config with a live streams coming in over RMTP. The live streams are setup to record. Using the Wowza Streaming Engine Manager i changed the setting for the "content" directory in both the livecf and the vodcf applications. I then started a stream, and the file is going to the new directory correctly. We use HLS over HTTP to playback the files. While the stream is live it plays fine. But the URL to VOD does not play and gives a file not found.

    The following are the URL's that we use to connect to the server:

    Livestream URL


    Now here is the part where I'm sure where I'm missing something. I went back and changed the content directory back to the ${com.wowza.wms.context.VHostConfigHome}/content directory. But I only changed it under the livecf content directory, the file went back to the original directory and both URL's work. I did not change the vodcf application setting, so I'm getting that feeling that I'm missing a changing something.

    So what am I missing here?



  2. #2


    Hello Dan,

    I have a couple of questions whosxe answers may help clea up the issue you are facing.

    First: Is the alternate location an "s3 bucket"?

    If it is have you reviewed the following article:

    Second: Are these files being "nested" in sub directories when they are being moved?

    If so you can try adjusting the url: VOD URL

    Jason Hatchett

  3. #3
    Join Date
    Mar 2016


    With the help of Wowza support I got this figured out. Going to document it here in case someone else does something a "silly" as me...

    The issue was with my application config. I had a "livecf" application and a "vodcf" application. (I don't know why I added the cf's when I originally set this up).

    As you can see from my VOD URL above, I'm pointing to the folder "vod", not "vodcf". Well instead of not working, I guess Wowza ended up pointing that "invalid" URL back at the "default" content directory. No matter what config I changed, the URL was going to serve from the default directory.

    Solution, I simply added an application named "vod" and the set the content directory to my new location, and everything worked fine.

Similar Threads

  1. Which EC2 instance type is best suited for large volume streaming
    By jachai in forum Performance Tuning Discussion
    Replies: 2
    Last Post: 02-11-2014, 01:58 AM
  2. Moving DVR content to another application folder
    By tavius in forum AddOn: Wowza nDVR
    Replies: 6
    Last Post: 11-26-2011, 07:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts