Results 1 to 2 of 2

Thread: REST API return no response

  1. #1
    Join Date
    Apr 2016
    Posts
    2

    Question REST API return no response

    [Help]
    I call REST API via PHP curl, but no response return.
    here is my conf/Server.xml:

    <?xml version="1.0" encoding="UTF-8"?>
    <Root version="2">
    <Server>
    <Name>Wowza Streaming Engine</Name>
    <Description>Wowza Streaming Engine is robust, customizable, and scalable server software that powers reliable streaming of high-quality video and audio to any device, anywhere.</Description>
    <RESTInterface>
    <Enable>true</Enable>
    <IPAddress>*</IPAddress>
    <Port>8087</Port>
    <!-- none, basic, digest-->
    <AuthenticationMethod>none</AuthenticationMethod>
    <DiagnosticURLEnable>true</DiagnosticURLEnable>
    <SSLConfig>
    <Enable>false</Enable>
    <KeyStorePath></KeyStorePath>
    <KeyStorePassword></KeyStorePassword>
    <KeyStoreType>JKS</KeyStoreType>
    <SSLProtocol>TLS</SSLProtocol>
    <Algorithm>SunX509</Algorithm>
    <CipherSuites></CipherSuites>
    <Protocols></Protocols>
    </SSLConfig>
    <IPWhiteList>*</IPWhiteList>
    <IPBlackList></IPBlackList>
    <EnableXMLFile>false</EnableXMLFile>
    <DocumentationServerEnable>true</DocumentationServerEnable>
    <DocumentationServerPort>8089</DocumentationServerPort>
    <!-- none, basic, digest-->
    <DocumentationServerAuthenticationMethod>none</DocumentationServerAuthenticationMethod>
    <Properties>
    <Property>
    <Name>restUserHTTPHeaders</Name>
    <Value>Access-Control-Allow-Origin:*|Access-Control-Allow-Methods:OPTIONS,GET,PUT,DELETE,POST|Access-Control-Allow-Headers:Content-Type</Value>
    </Property>

    </Properties>
    </RESTInterface>
    <CommandInterface>
    <HostPort>
    <ProcessorCount>${com.wowza.wms.TuningAuto}</ProcessorCount>
    <IpAddress>*</IpAddress>
    <Port>8083</Port>
    </HostPort>
    </CommandInterface>
    <AdminInterface>
    <!-- Objects exposed through JMX interface: Server, VHost, VHostItem, Application, ApplicationInstance, MediaCaster, Module, Client, MediaStream, SharedObject, Acceptor, IdleWorker -->
    <ObjectList>Server,VHost,VHostItem,Application,ApplicationInstance,MediaCaster,Module,IdleWorker</ObjectList>
    </AdminInterface>
    <Stats>
    <Enable>true</Enable>
    </Stats>
    <!-- JMXUrl: service:jmx:rmi://localhost:8084/jndi/rmi://localhost:8085/jmxrmi -->
    <JMXRemoteConfiguration>
    <Enable>false</Enable>
    <IpAddress>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_IPV4}</IpAddress> <!--changed for default Amazon cloud install. <IpAddress>localhost</IpAddress>--> <!-- set to localhost or internal ip address if behind NAT -->
    <RMIServerHostName>${com.wowza.amazonaws.ec2.AWSEC2_METADATA_PUBLIC_HOSTNAME}</RMIServerHostName> <!--changed for default Amazon cloud install. <RMIServerHostName>localhost</RMIServerHostName>--> <!-- set to external ip address or domain name if behind NAT -->
    <RMIConnectionPort>8084</RMIConnectionPort>
    <RMIRegistryPort>8085</RMIRegistryPort>
    <Authenticate>true</Authenticate>
    <PasswordFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.password</PasswordFile>
    <AccessFile>${com.wowza.wms.ConfigHome}/conf/jmxremote.access</AccessFile>
    <SSLSecure>false</SSLSecure>
    </JMXRemoteConfiguration>
    <UserAgents>Shockwave Flash|CFNetwork|MacNetwork/1.0 (Macintosh)</UserAgents>
    <Streams>
    <DefaultStreamPrefix>mp4</DefaultStreamPrefix>
    </Streams>
    <ServerListeners>
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.amazonaws.ec2.env.ServerListenerEC2Variables</BaseClass>
    </ServerListener> <!--changed for default Amazon cloud install. -->
    <ServerListener>
    <BaseClass>com.wowza.wms.mediacache.impl.MediaCacheServerListener</BaseClass>
    </ServerListener>
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerListener</BaseClass>
    </ServerListener>
    -->
    <!--
    <ServerListener>
    <BaseClass>com.wowza.wms.plugin.loadbalancer.ServerListenerLoadBalancerSender</BaseClass>
    </ServerListener>
    -->
    </ServerListeners>
    <VHostListeners>
    <!--
    <VHostListener>
    <BaseClass></BaseClass>
    </VHostListener>
    -->
    </VHostListeners>
    <HandlerThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </HandlerThreadPool>
    <TransportThreadPool>
    <PoolSize>${com.wowza.wms.TuningAuto}</PoolSize>
    </TransportThreadPool>
    <RTP>
    <DatagramStartingPort>6970</DatagramStartingPort>
    <DatagramPortSharing>false</DatagramPortSharing>
    </RTP>

    <Manager>
    <!-- Properties defined are used by the Manager -->
    <Properties>
    </Properties>
    </Manager>

    <!-- Properties defined here will be added to the IServer.getProperties() collection -->
    <Properties>
    </Properties>
    </Server>
    </Root>

    Help me please.
    Thank all.

  2. #2

    Default

    Hello

    Your Server.xml looks correct (though it is set-up without authentication for the REST calls which is not a problem in a test environment, but not recommended in a production environment), have you been able to access the documentation to run some test calls from the same machine that you have your Wowza Streaming Engine Instance installed on?

    https://www.wowza.com/forums/content...ngine-REST-API

    Regards
    Jason Hatchett

Similar Threads

  1. Response details for REST API monitoring/historic
    By chrisdeely in forum Wowza Streaming Engine REST API
    Replies: 7
    Last Post: 08-08-2016, 10:11 AM
  2. Json Response Content-Type of REST API
    By featheast in forum Wowza Streaming Engine REST API
    Replies: 1
    Last Post: 02-04-2016, 10:47 AM
  3. The API should return JSON instead of plain HTML
    By cmelendez in forum Suggestions
    Replies: 1
    Last Post: 03-19-2014, 02:01 PM
  4. Response return by http provider in demand recording
    By kavita in forum Video On Demand Streaming Discussion
    Replies: 2
    Last Post: 06-02-2013, 10:34 PM
  5. Recording File Path Changing and HTTP API stopping response
    By magicpro in forum AddOn: Other AddOns
    Replies: 1
    Last Post: 07-17-2012, 09:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •