Results 1 to 2 of 2

Thread: MultitrackVOD on wowza

  1. #1
    Join Date
    Jul 2016
    Posts
    1

    Default MultitrackVOD on wowza

    Hi everyone,
    I installed multitrackVOD module (add module on web, add jar file in library) on wowza streaming engine in order to choose audio option (language: english, vietnamese, chinese...) on video mp4 file. After, I created smil file for multitrackVOD but I can't choose audio option.
    This is url for mp4 file and smil of me:
    https://www.dropbox.com/s/qirlugw85v...ckVOD.rar?dl=0

    This is url for playing multitrackVOD:
    http://112.197.10.222:1935/vod/_defi.../playlist.m3u8
    http://112.197.10.222:1935/vod/_defi...8?audioindex=3

    Content of smil file:
    <smil>
    <head>
    </head>
    <body>
    <switch>
    <video src="mp4:Canhsatsieunang01_1500.mp4?audioindex=2" system-language="vi" title="Vietnam" audio-bitrate="192000">
    <param name="audioOnly" value="TRUE" valuetype="data"/>
    <param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    <param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    <param name="cupertinoTag.DEFAULT" value="YES" valuetype="data"/>
    </video>
    <video src="mp4:Canhsatsieunang01_1500.mp4?audioindex=3" system-language="zh" title="China" audio-bitrate="192000">
    <param name="audioOnly" value="TRUE" valuetype="data"/>
    <param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    <param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    <param name="cupertinoTag.DEFAULT" value="FALSE" valuetype="data"/>
    </video>
    <video src="mp4:Canhsatsieunang01_1500.mp4?audioindex=4" system-language="zh" title="China" audio-bitrate="192000">
    <param name="audioOnly" value="TRUE" valuetype="data"/>
    <param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    <param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    <param name="cupertinoTag.DEFAULT" value="FALSE" valuetype="data"/>
    </video>
    <video src="mp4:Canhsatsieunang01_1500.mp4?audioindex=5" system-language="zh" title="China" audio-bitrate="192000">
    <param name="audioOnly" value="TRUE" valuetype="data"/>
    <param name="cupertinoTag" value="EXT-X-MEDIA" valuetype="data"/>
    <param name="cupertinoTag.GROUP-ID" value="aac" valuetype="data"/>
    <param name="cupertinoTag.DEFAULT" value="FALSE" valuetype="data"/>
    </video>
    <video src="mp4:Canhsatsieunang01_1500.mp4" width="854" height="480" video-bitrate="1267000">
    <param name="videoCodecId" value="avc1" valuetype="data"/>
    <param name="videoOnly" value="TRUE" valuetype="data"/>
    <param name="cupertinoTag.AUDIO" value="aac" valuetype="data"/>
    <param name="audioCodecId" value="mp4a.40" valuetype="data"/>
    </video>
    </switch>
    </body>
    </smil>

    I did correctly the guide but it couldn't choose audio option. So that, I hope everyone to help me fix this bug.
    Last edited by dinhduc; 07-14-2016 at 02:41 AM.

  2. #2

    Default

    Hi,

    I believe we worked with you on this within our ticket process? One thing I'd suggest if you haven't already is to make each "title=" refer to a unique name. I could play your stream using the JW Stream Tester and was able to switch audio tracks, though the second and fourth were problematic, probably due to having the same title values.


    Regards,

    Paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •