Wowza Community

help installing JRE on Linux?

Hi all-

I have a dedicated box, and my hosting company will not install 3rd party apps.

Does anyone have a good walk-through for installing JRE so I can then install Wowza?


Pretty simple. Download Java JDK 6 Update 10 from here (probably the .rpm.bin is the best one):

do a chmod to make give it execute privs:

chmod +x [filename].rpm.bin

run the installer:


That is it. You should be able to execute the java command to see if it the correct version:

java -version

If not follow these instructions:


Is this a virtual private server? How much memory is in the machine? You may need to set the heap size to a very low value to start the server. To do this edit the file [install-dir]/bin/ and change the Java heap size:


You may need to try lower values. The problem with this setup is that you are not going to be able to handle many concurrent connections with this much memory. I am also concerned about the initial Java installation that failed. I am not confident that Java is installed properly.


I am not sure. What I would do is uninstall the jre/jdk, upgrade the memory, re-install. To uninstall, find the name of the install by executing the command:

rpm -qa | grep jdk
rpm -qa | grep jre

It should return a list of all the JDK’s or JRE’s you have installed. To uninstall, execute the command:

rpm -e [name-of-jdk-or-jre-returned-above]

For example for me it is:

rpm -e jdk-1.6.0_10-fcs


I guess I would just go with it the way it is.


That looks right to me. Should be ready to install Wowza.

thanks - will try and see what happens!

UPDATE: found the answer!

error: can’t create transaction lock on /var/lib/rpm/__db.000

now what?:confused:

thanks in advance -

ok… I rec’d this error

error: %post(jre-1.6.0_10-fcs.i586) scriptlet failed, exit status 5

after it unpacked, but when i ran java -version it showed

java version “1.6.0_10”

Java™ SE Runtime Environment (build 1.6.0_10-b33)

Java HotSpot™ Client VM (build 11.0-b15, mixed mode, sharing)

should I assume I’m ok at this point?


oh sigh…

now getting

[root@domain wowza]# cd /usr/local/WowzaMediaServerPro/bin

[root@domain bin]# ./

Error occurred during initialization of VM

Could not reserve enough space for object heap

Could not create the Java virtual machine.

yes, it is a virtual dedicated server.

how do I test the JRE install?

Thanks for the quick reply. :slight_smile:

I uninstalled, had the host upgrade memory/processor, and reinstalled JRE pkg.

Once it unpacked the jar files, it showed

error: %post(jre-1.6.0_10-fcs.i586) scriptlet failed, exit status 5


Then I ran java -version, it showed

java version “1.6.0_10”

Java™ SE Runtime Environment (build 1.6.0_10-b33)

Java HotSpot™ Server VM (build 11.0-b15, mixed mode)

I did find this in the Java bug database, but it doesn’t tell me if the version of Java is installed correctly or not:

Any Suggestions? My host (Media Temple) refuses to support 3rd-party apps, and they consider Java a 3rd party application.