Wowza Community

How to re-stream an unprotected stream from FMS or a CDN such as Akamai

Works okay in Wowza Flash player from here

Server: rtmp://

Stream: T00304@20413

The ticker is smooth and the audio is great, for me at my location.

What is the bitrate? Choppy playback in Flash is usually a bitrate/bandwidth issue.


What URL are you using for iOS playback? I tried this but there is no playlist:

Is this CDN URL to an FMS server?



Yes, this is still the same. It only works with un-protected steams.


I understand that, but how I generate the smil?

If I have and, how do I insert that into the .smil file?

I mean, for example in an standard .smil you have:

In the streamname field should I put, ??

Thanks Richard

Ok, but how do I access to the smil file with the iphone browser?

Do I need to create a third application? If I have one application for the first stream and other for the second stream, I would need a third application for indexing the smil, right?

Trying as I write this lines…

Edit: Finally I used another stream under the same application and it works, thank you very much for your help Richard.

Is there support for Akamai token based streaming on wowza reflectors, pulling streams from Akamai?


Akamai has a way to secure media streams. They generate “tokens” which the client needs to provide to the Akamai server whenever they need to fetch a stream.

The token is appended to the stream name & the url looks like this:


Look at “auth=”. Will a Wowza reflector re-streaming an Akamai stream, support this functionality?

If yes, what do I need to configure?

If no, do you have any work around, even if it means extra code?


Is there a way I could re-write my own live repeater, which supports query parameters?

The first step is to be able to subscribe to live streams from other servers. I think, in the previous versions of wowza, this was not possible. Is this possible in Wowza 2?

The second step would be to republish these streams for clients on this server. I saw support for vod streams using Stream class in Wowza 2. Can this be done for live streams?

Any ideas here?


Yes, many CDNs use the Wowza Server to power their network. Many of those CDNs will permit you to setup the live stream repeater function on your own Wowza Server which will act as an origination point for the stream going into the network. You’ll need to check with the CDN’s staff on what business arrangements and configurations must be made to make this work with their network.

If you have an existing business arrangement with Akamai which ties you to using their network, I’m happy to discuss this next week (I’ve received your email and will reply shortly).


John West

john [at] wowzamedia {dotCom}

The Live Streaming step says

Set the Streams/StreamType property to: liverepeater-edge

but the Live Streaming (all player technologies) says

Set the Streams/StreamType property to: live

which seems to require setting up the akamai connection through the stream manager.

Is it possible to have the automatic connection to akamai and still stream to the iphone? if I just change Streams/StreamType to liverepeater-edge it says Stream not found

I have a few live streaming shows that are on at different times of the day ranging from 10 minutes to 3 hours.

I don’t have any problems restreaming them from akamai to devices using the techniques described here. I’m trying to use the StartupStreams.xml but now my logs are filled with



LiveMediaStreamHandler.sessionClosed: reconnect: isCurrentSession:false tryConnect:true

which seems like a problem. I’d hope it was only connecting to akamai when someone was trying to get the restream rather than constantly connecting. Am I using the wrong approach for this kind of situation?

I’m not aware of StreamManager , is this an Akamai function

do you have more info about it ?


thanks , but I still can’t see how can I use this with Akamai for live streaming

is it any solution how to use akamai or any other CDN as edge ? because I have my custom modules installed on my wowza server and no CDN allows the things to been installed on their servers , so it must been a work around it , I know some sites doing it but can’t ask them about their solution :slight_smile:

Hello, I am getting this warning:

WARN vhost comment defaultVHost Bind failed, try again ([any]:1935): Address already in use

And, I cannot seem to stop the server or change to a directory

Thank you.

I got the stream going thank you, however please see my other post as my stream is not working properly.

I am streaming on iPhone.

Very happy about it. We will be purchasing a perpetual license tomorrow, Sunday PST.

Right now we are running a Wowza Server Subscription for a single instance.

After we have the stream going in the iPhone it lasts without stopping.

But, there is an issue. The stream doesn’t always stream when the address is entered into the browser. After closing the Safari browser we just get a blank screen in the browser if we try to stream again. But, after waiting some time it will work again.

We get a WARN server comment - HTTPStreamerAdopterCupertinoStreaming.onPlaylist: Application context no loaded []: defapp/definst

Thank you

i have a situation :frowning:

i sent my stream from FME to FMS and i can view it by


learner is my stream.

but how will i put this in for the wowza to pull?

i tried this

rtmp:// didnt work

rtmp:// didnt work either :frowning:

help me out. thx

the text editor doesnt add a .txt extension but wowza just dont pull it or restream it :frowning:


Is it still the case that you can not pass parameters to a startup stream via the .stream file ( See your previous comment )?

I have a case where we are trying to use Wowza to record a protected stream from BitGravity. The .stream file look something like this (a bit obscured):


Using that we get repeated:


LiveMediaStreamReceiver.sessionClosed: reconnect: isCurrentSession:true tryConnect:true

The h= parameter is the specific hash code for that stream. We have no problem starting the stream and streaming it if the stream is unprotected and does not need parameters. The same above stream URL works just fine if given to JWPlayer alone. Just wondering if passing URL parameters had been addressed yet, or if there is another way around this problem.