Wowza Community

Ingest UDP mpeg-ts from ffmpeg

Hi there,

I have followed the instructions from

with my stream file pointing to udp://

and my FFMPEG commands are as follow:

ffmpeg -re -f lavfi -i testsrc=size=1280x720:rate=30 -c:v libx264 -b:v 1M -preset ultrafast -b:a 128k -c:a libfdk_aac -s 1280x720 -g 30 -pix_fmt yuv420p -bsf:v h264_mp4toannexb -f mpegts udp://

I have verified the UDP stream output from FFMPEG using

mpv udp://

we know that FFMPEG is indeed outputting the stream.

However, I have 2 issues:

First being even though I can see the ‘live’ Application I have setup to load the stream file, and saw an incoming stream with udp://, and further confirmed the traffic Network has 1Mbps “Bits In”, I do not see any “Bits Out”, and I cannot see any streams output, say

curl -i

returns HTTP 404 not found.

Second being I cannot apply a stream file to a custom Application, after I connect the stream file to the custom Application, it said Connect Successful, but I do not see an incoming stream. Maybe the UDP issue aforementioned hindered the addition of stream file perhaps?

Thank you!

Have you tested with other protocols - rtmp/rtsp outputs for publishing to wowza with your ffmpeg command.

Yes, I have tested with RTMP, and it worked fine with the ffmpeg command with the same setup publishing to wowza. But our target is to use UDP/MPEGTS.

There seems to be a similar post in the forum on same topic. Try to see if using your ffmpeg command that way helps.

Hi @Connessione, thank you for answering. Unfortunately that post doesn’t seem to reconcile my situation.
I have tried different combinations of framerates & bitrates & resolutions, including his config, all have failed to establish an output stream.

server (200) HTTPStreamerAdapterCupertinoStreamer.onPlaylist: Stream not found [udp/myStream/playlist.m3u8]: myStream x-vhost: defaultVHost, x-app: udp, x-appinst: definst, x-duration: 1838.21

logs stated the stream cannot be found, when we attempted to request a stream (HLS/DASH).
logs are in following sequence:
connect cupertino (200)
create stream (200)
comment server (200) : Stream not found
destroy stream (200)
disconnect cupertino (200)

However we do see the server continues to add chunks & segments despite of no output stream exists.
server (200) LiveStreamPacketizerCupertino.endChunkTS[udp/definst/]: Add chunk: id:11 mode:TS[H264,AAC] a/v/k:432/250/10 duration:10000 x-duration: 1829740.355

It seems to me that Wowza Streaming Engine doesn’t know how to create a manifest (HLS/DASH) despite having the MPEG-TS segments received.
Are there any custom settings inside Application/Server we need to enable perhaps?

Thank you in advanced.

Hey man I hope you found a lead on your issue. I haven’t had time to go deeper into your issue so far personally.